[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#305230: [sparc64] [rc3] [netinstall] RC3 does not work on Ultra5 with both kernels 2.4 and 2.6



Package: installation-reports
Severity: critical
Justification: breaks the whole system

*** Please type your report below this line ***
INSTALL REPORT

Debian-installer-version: RC3
uname -a: Linux morea 2.6.8-2-sparc64 #1 Tue Dec 28 12:20:13 PST 2004 sparc64 GNU/Linux
Date: 2005-04-13
Method: How did you install?  What did you boot off?  If network
      install, from where?  Proxied?

We used a network install, with net boot, with a debian mirror on local LAN.

Machine: SUN UltraSparc 5 
Processor: TI UltraSparc IIi (Sabre)
Memory: 384 MiB
Root Device: IDE. hda2

Root Size/partition table:  default partitionning of RC3:
# fdisk -l /dev/hda
Disk /dev/hda (Sun disk label): 16 heads, 63 sectors, 16708 cylinders
Units = cylinders of 1008 * 512 bytes

   Device Flag    Start       End    Blocks   Id  System
/dev/hda1             0       194     97776    1  Boot           /boot
/dev/hda2           194     15933   7932456   83  Linux native   /
/dev/hda3             0     16708   8420832    5  Whole disk
/dev/hda4         15933     16708    390600   82  Linux swap     swap

Output of lspci and lspci -n:
# lspci 
0000:00:00.0 Host bridge: Sun Microsystems Computer Corp. Ultra IIi
0000:00:01.0 PCI bridge: Sun Microsystems Computer Corp. Simba Advanced PCI Bridge (rev 13)
0000:00:01.1 PCI bridge: Sun Microsystems Computer Corp. Simba Advanced PCI Bridge (rev 13)
0000:01:01.0 Bridge: Sun Microsystems Computer Corp. EBUS (rev 01)
0000:01:01.1 Ethernet controller: Sun Microsystems Computer Corp. Happy Meal (rev 01)
0000:01:02.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro 215GP (rev 5c)
0000:01:03.0 IDE interface: Silicon Image, Inc. (formerly CMD Technology Inc) PCI0646 (rev 03)

# lspci -n
0000:00:00.0 0600: 108e:a000
0000:00:01.0 0604: 108e:5000 (rev 13)
0000:00:01.1 0604: 108e:5000 (rev 13)
0000:01:01.0 0680: 108e:1000 (rev 01)
0000:01:01.1 0200: 108e:1001 (rev 01)
0000:01:02.0 0300: 1002:4750 (rev 5c)
0000:01:03.0 0101: 1095:0646 (rev 03)



Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]

Comments/Problems:
We tried to install RC3 on an Ultra5 machine. It failed with both kernels.

 - with kernel 2.4

[...]  unable to read partition table

[...]

VFS: Cannot open root device "hda2" or 03:02


 - with kernel 2.6

Remapping the kernel... Fast Instruction Access MMU Miss

It seems similar to:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=299043
http://lists.debian.org/debian-kernel/2005/03/msg00163.html


Install logs and other status info is available in /var/log/debian-installer/.
Once you have filled out this report, mail it to submit@bugs.debian.org.


The installation succeded with the daily built of 2005-04-13.


-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: sparc (sparc64)
Kernel: Linux 2.6.8-2-sparc64
Locale: LANG=fr_FR@euro, LC_CTYPE=fr_FR@euro (charmap=ISO-8859-15)



-- 
 david.mentre@gmail.com




Reply to: