[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#303432: installation report: no network since forcedeth not loaded

Package: installation-reports


Debian-installer-version: 20050330 snapshot from cdimage.debian.org
uname -a: Linux desk 2.6.8-2-386 #1 Mon Jan 24 03:01:58 EST 2005 i686 GNU/Linux
Date: 2005-04-01
Method: netinst CD-ROM with base system, accessing .de Debian mirror via
	masquerading gateway

Machine: Shuttle xPC SN45G with Shuttle FN45 mainboard
Processor: Athlon XP 2800+
Memory: 512 MB
Root Device: 30 GB IDE HDD, /dev/hda2
Root Size/partition table:
      major minor  #blocks  name
        3     0   29316672 hda
        3     1      96358 hda1
        3     2    6739267 hda2
        3     3     979965 hda3
        3     4   21494970 hda4
      254     0   10485760 dm-0

      /dev/hda2       /               xfs     defaults        0       1
      /dev/hda1       /boot           ext3    defaults        0       2
      /dev/mapper/lvspace-home_andreas /home/andreas   xfs     defaults
      0       2
      /dev/hda3       none            swap    sw              0       0
Output of lspci and lspci -n:
	desk:~# lspci
	0000:00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev c1)
	0000:00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
	0000:00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
	0000:00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
	0000:00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
	0000:00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
	0000:00:01.0 ISA bridge: nVidia Corporation: Unknown device 0080 (rev a3)
	0000:00:01.1 SMBus: nVidia Corporation: Unknown device 0084 (rev a1)
	0000:00:02.0 USB Controller: nVidia Corporation: Unknown device 0087 (rev a1)
	0000:00:02.1 USB Controller: nVidia Corporation: Unknown device 0087 (rev a1)
	0000:00:02.2 USB Controller: nVidia Corporation: Unknown device 0088 (rev a2)
	0000:00:04.0 Bridge: nVidia Corporation: Unknown device 008c (rev a3)
	0000:00:06.0 Multimedia audio controller: nVidia Corporation: Unknown device 008a (rev a1)
	0000:00:08.0 PCI bridge: nVidia Corporation: Unknown device 008b (rev a3)
	0000:00:09.0 IDE interface: nVidia Corporation: Unknown device 0085 (rev a3)
	0000:00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
	0000:01:04.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
	0000:02:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

	desk:~# lspci -n
	0000:00:00.0 0600: 10de:01e0 (rev c1)
	0000:00:00.1 0500: 10de:01eb (rev c1)
	0000:00:00.2 0500: 10de:01ee (rev c1)
	0000:00:00.3 0500: 10de:01ed (rev c1)
	0000:00:00.4 0500: 10de:01ec (rev c1)
	0000:00:00.5 0500: 10de:01ef (rev c1)
	0000:00:01.0 0601: 10de:0080 (rev a3)
	0000:00:01.1 0c05: 10de:0084 (rev a1)
	0000:00:02.0 0c03: 10de:0087 (rev a1)
	0000:00:02.1 0c03: 10de:0087 (rev a1)
	0000:00:02.2 0c03: 10de:0088 (rev a2)
	0000:00:04.0 0680: 10de:008c (rev a3)
	0000:00:06.0 0401: 10de:008a (rev a1)
	0000:00:08.0 0604: 10de:008b (rev a3)
	0000:00:09.0 0101: 10de:0085 (rev a3)
	0000:00:1e.0 0604: 10de:01e8 (rev c1)
	0000:01:04.0 0c00: 1106:3044 (rev 80)
	0000:02:00.0 0300: 10de:0322 (rev a1)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


Booting without additional options proceeded until network
configuration, where it didn't find any devices.  Changing to the second
console and manually doing 'modprobe forcedeth' (after lots of googling
to determine that this is the one I needed) resulted in no success:  The
driver aborted initialization with a "No such device" error.

The next attempt was booting with linux26, which got to network
configuration and tried to configure eth0 via DHCP.  This failed with
timeouts.  After checking many different things (cabling, DHCP server,
...) I finally noticed that the ethernet device still isn't configured
and eth0 was ip1394 instead, which got automatically loaded on the
existing FireWire interface.

Manually modprobing forcedeth works with the 2.6 kernel and gave me
eth1.  In the installer, I returned to the main menu and restarted
network configuration.  Now I could choose eth1, it DHCPed correctly,
and the rest of the installation went on flawlessly.  After reboot, eth1
was correctly set up.  Good work.

Apart from the fact that forcedeth just wasn't automatically loaded
correctly during installation, the ip1394 module provided eth0 and was
misleading in troubleshooting the failing DHCP.  I think it would help
if either 
a) the installer would give a notice when the only available interface
   is "unusual" (i.e. not Ethernet or WLAN) though probably it's hard to
   define what should be unusual; or
b) the interface selection with the information on the network type
   behind the interface would be shown even if there is only one
   interface; or
c) the hardware type would be shown during attempted DHCP.

Other small things:

I didn't get any message that GRUB could not be installed with /boot on
XFS.  Since I want to use it, I had to go back and repartition to
include a small ext3 /boot partition, wasting a lot of time.

I don't know if this belongs with the installer or somewhere else, but
anacron was not automatically installed.  I consider it essential for
any non-server system that is not expected to run 24/7.

Andreas Bombe <bombe@informatik.tu-muenchen.de>    GPG key 0x04880A44

Reply to: