[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#303432: marked as done (installation report: no network since forcedeth not loaded)

Your message dated Sun, 24 Apr 2005 00:02:23 -0400
with message-id <E1DPYK7-0004pH-00@newraff.debian.org>
and subject line Bug#299824: fixed in discover1-data 1.2005.04.23
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 6 Apr 2005 17:17:02 +0000
>From andreas@infernal.debian.net Wed Apr 06 10:17:02 2005
Return-path: <andreas@infernal.debian.net>
Received: from mailout1.informatik.tu-muenchen.de [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1DJE9F-0004O3-00; Wed, 06 Apr 2005 10:17:01 -0700
Received: by amos.infernal (Postfix, from userid 1000)
	id 805655C0E9; Wed,  6 Apr 2005 19:16:58 +0200 (CEST)
Date: Wed, 6 Apr 2005 19:16:58 +0200
From: Andreas Bombe <aeb@debian.org>
To: submit@bugs.debian.org
Subject: installation report: no network since forcedeth not loaded
Message-ID: <[🔎] 20050406171658.GA4168@infernal.debian.net>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.5.6+20040907i
X-Virus-Scanned: by amavisd-new/sophie/sophos at mailrelay1.informatik.tu-muenchen.de
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: installation-reports


Debian-installer-version: 20050330 snapshot from cdimage.debian.org
uname -a: Linux desk 2.6.8-2-386 #1 Mon Jan 24 03:01:58 EST 2005 i686 GNU/Linux
Date: 2005-04-01
Method: netinst CD-ROM with base system, accessing .de Debian mirror via
	masquerading gateway

Machine: Shuttle xPC SN45G with Shuttle FN45 mainboard
Processor: Athlon XP 2800+
Memory: 512 MB
Root Device: 30 GB IDE HDD, /dev/hda2
Root Size/partition table:
      major minor  #blocks  name
        3     0   29316672 hda
        3     1      96358 hda1
        3     2    6739267 hda2
        3     3     979965 hda3
        3     4   21494970 hda4
      254     0   10485760 dm-0

      /dev/hda2       /               xfs     defaults        0       1
      /dev/hda1       /boot           ext3    defaults        0       2
      /dev/mapper/lvspace-home_andreas /home/andreas   xfs     defaults
      0       2
      /dev/hda3       none            swap    sw              0       0
Output of lspci and lspci -n:
	desk:~# lspci
	0000:00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev c1)
	0000:00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
	0000:00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
	0000:00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
	0000:00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
	0000:00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
	0000:00:01.0 ISA bridge: nVidia Corporation: Unknown device 0080 (rev a3)
	0000:00:01.1 SMBus: nVidia Corporation: Unknown device 0084 (rev a1)
	0000:00:02.0 USB Controller: nVidia Corporation: Unknown device 0087 (rev a1)
	0000:00:02.1 USB Controller: nVidia Corporation: Unknown device 0087 (rev a1)
	0000:00:02.2 USB Controller: nVidia Corporation: Unknown device 0088 (rev a2)
	0000:00:04.0 Bridge: nVidia Corporation: Unknown device 008c (rev a3)
	0000:00:06.0 Multimedia audio controller: nVidia Corporation: Unknown device 008a (rev a1)
	0000:00:08.0 PCI bridge: nVidia Corporation: Unknown device 008b (rev a3)
	0000:00:09.0 IDE interface: nVidia Corporation: Unknown device 0085 (rev a3)
	0000:00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
	0000:01:04.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
	0000:02:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

	desk:~# lspci -n
	0000:00:00.0 0600: 10de:01e0 (rev c1)
	0000:00:00.1 0500: 10de:01eb (rev c1)
	0000:00:00.2 0500: 10de:01ee (rev c1)
	0000:00:00.3 0500: 10de:01ed (rev c1)
	0000:00:00.4 0500: 10de:01ec (rev c1)
	0000:00:00.5 0500: 10de:01ef (rev c1)
	0000:00:01.0 0601: 10de:0080 (rev a3)
	0000:00:01.1 0c05: 10de:0084 (rev a1)
	0000:00:02.0 0c03: 10de:0087 (rev a1)
	0000:00:02.1 0c03: 10de:0087 (rev a1)
	0000:00:02.2 0c03: 10de:0088 (rev a2)
	0000:00:04.0 0680: 10de:008c (rev a3)
	0000:00:06.0 0401: 10de:008a (rev a1)
	0000:00:08.0 0604: 10de:008b (rev a3)
	0000:00:09.0 0101: 10de:0085 (rev a3)
	0000:00:1e.0 0604: 10de:01e8 (rev c1)
	0000:01:04.0 0c00: 1106:3044 (rev 80)
	0000:02:00.0 0300: 10de:0322 (rev a1)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


Booting without additional options proceeded until network
configuration, where it didn't find any devices.  Changing to the second
console and manually doing 'modprobe forcedeth' (after lots of googling
to determine that this is the one I needed) resulted in no success:  The
driver aborted initialization with a "No such device" error.

The next attempt was booting with linux26, which got to network
configuration and tried to configure eth0 via DHCP.  This failed with
timeouts.  After checking many different things (cabling, DHCP server,
...) I finally noticed that the ethernet device still isn't configured
and eth0 was ip1394 instead, which got automatically loaded on the
existing FireWire interface.

Manually modprobing forcedeth works with the 2.6 kernel and gave me
eth1.  In the installer, I returned to the main menu and restarted
network configuration.  Now I could choose eth1, it DHCPed correctly,
and the rest of the installation went on flawlessly.  After reboot, eth1
was correctly set up.  Good work.

Apart from the fact that forcedeth just wasn't automatically loaded
correctly during installation, the ip1394 module provided eth0 and was
misleading in troubleshooting the failing DHCP.  I think it would help
if either 
a) the installer would give a notice when the only available interface
   is "unusual" (i.e. not Ethernet or WLAN) though probably it's hard to
   define what should be unusual; or
b) the interface selection with the information on the network type
   behind the interface would be shown even if there is only one
   interface; or
c) the hardware type would be shown during attempted DHCP.

Other small things:

I didn't get any message that GRUB could not be installed with /boot on
XFS.  Since I want to use it, I had to go back and repartition to
include a small ext3 /boot partition, wasting a lot of time.

I don't know if this belongs with the installer or somewhere else, but
anacron was not automatically installed.  I consider it essential for
any non-server system that is not expected to run 24/7.

Andreas Bombe <bombe@informatik.tu-muenchen.de>    GPG key 0x04880A44

Received: (at 299824-close) by bugs.debian.org; 24 Apr 2005 04:12:18 +0000
>From katie@ftp-master.debian.org Sat Apr 23 21:12:18 2005
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1DPYTi-0007tW-00; Sat, 23 Apr 2005 21:12:18 -0700
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1DPYK7-0004pH-00; Sun, 24 Apr 2005 00:02:23 -0400
From: Joshua Kwan <joshk@triplehelix.org>
To: 299824-close@bugs.debian.org
X-Katie: $Revision: 1.55 $
Subject: Bug#299824: fixed in discover1-data 1.2005.04.23
Message-Id: <E1DPYK7-0004pH-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Sun, 24 Apr 2005 00:02:23 -0400
Delivered-To: 299824-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-CrossAssassin-Score: 2

Source: discover1-data
Source-Version: 1.2005.04.23

We believe that the bug you reported is fixed in the latest version of
discover1-data, which is due to be installed in the Debian FTP archive:

  to pool/main/d/discover1-data/discover1-data-udeb_1.2005.04.23_all.udeb
  to pool/main/d/discover1-data/discover1-data_1.2005.04.23.dsc
  to pool/main/d/discover1-data/discover1-data_1.2005.04.23.tar.gz
  to pool/main/d/discover1-data/discover1-data_1.2005.04.23_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 299824@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joshua Kwan <joshk@triplehelix.org> (supplier of updated discover1-data package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sat, 23 Apr 2005 20:36:07 -0700
Source: discover1-data
Binary: discover1-data discover1-data-udeb
Architecture: source all
Version: 1.2005.04.23
Distribution: unstable
Urgency: medium
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joshua Kwan <joshk@triplehelix.org>
 discover1-data - hardware lists for libdiscover1
 discover1-data-udeb - hardware lists for libdiscover1 (short list) (udeb)
Closes: 274039 283399 299824 302785
 discover1-data (1.2005.04.23) unstable; urgency=medium
   * Petter Reinholdtsen
     - PCI entry 11864c00 uses kernel module sk98lin, at least for
       kernel 2.6.8-1-386. (Closes: #302785)
     - List a few likely broadcom ethernet devices as such.
     - Try to load the correct X driver for ATI Radeon 9600,
       PCI ID 10024172. (Closes: #274039)
     - Updated several unknown devices based on kernel 2.4.27-1-686
       module info.
     - Set 'usb' device type on several devices with 'USB' and
       'Controller' in the name.
     - PCI entries 10de01c3, 10de0066, 10de00d6, 10de0086, 10de008c,
       10de00e6, 10de00df, 10de0056, 10de0057, 10de0037 and 10de0038
       uses ethernet module forcedeth. (Closes: #299824 #305336)
     - PCI entry 10025835 is a video card using XFree86 module radeon.
       (Closes: #283399)
     - Updated pci.lst using hw-db-merge.pl to include the latest IDs
       and names from <URL:http://pciids.sourceforge.net/pci.ids.gz>.
   * Joshua Kwan
     - Add ipw2200 for 8086:4220, 8086:4223 (special module > no module.)
     - Add snd-intel8x0m for 8086:24c6 (ditto)
   * Gaudenz Steinlin
     - Add ata_piix for 8086:2653
 83fe56a9ab8166ae0616077eac6ee772 1434 libs optional discover1-data_1.2005.04.23.dsc
 2d9b9b926cef298b07a3bcf8035e790a 118014 libs optional discover1-data_1.2005.04.23.tar.gz
 9ca34e99eb64de7c2139ef93a156b446 103620 libs optional discover1-data_1.2005.04.23_all.deb
 d561a322b767fe8792a469a2cf2499a7 17194 debian-installer extra discover1-data-udeb_1.2005.04.23_all.udeb
package-type: udeb
Version: GnuPG v1.4.0 (GNU/Linux)
Comment: http://triplehelix.org/~joshk/pubkey_gpg.asc


Reply to: