[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems booting into Debian installer on PowerMac G5


This is just an update after talking to someone on #debian

After the installer partitions the drives I dropped into the shell and
executed the following:

$ cd /target
$ chroot .
$ ybin -v -v

This produced a few lines of output and stated that it had blessed
/dev/sda1 with Holy Penguin Pee. Shouldn't this have read "hda"?

Using mac-fdisk to look at the partition map of /dev/sda I got the
following output:

Apple_partition_map ... Partition map
Apple_Bootstrap ... NewWorld bootblock
Apple_UNIX_SVR2 ... Linux native
Apple_UNIX_SVR2 ... Linux swap

This all looked fine, so I did the following:

$ mkdir /mnt/tmp
$ mount /dev/sda1 /mnt/tmp

This gave the following error:

"Invalid Argument ... You must specify the filesystem type"

After some futile attempts to get this working, I tried the following:

$ mount /dev/sda2 /mnt/tmp
$ ls -l /mnt/tmp

This was the output:


So, all looks good here too.

I rebooted and... nothing, yaboot presented me with the option screen,
but "l" still didn't work and it just hangs for a while and goes back
to the selection screen.

So, I'm thinking - perhaps an issue with the kernel?

So I tried all the above steps again twice over, each time using
apt-get to install the following kernels respectively:


Even with the new kernel, I was still getting the same problem.

BTW, I did check /etc/yaboot.conf and in each case it was pointing to
the right kernel.

I hope this helps shed at least *some* more light on my situation.

Does anyone have an idea where this is going wrong?


On Apr 3, 2005 4:21 AM, Noah Slater <nslater@gmail.com> wrote:
> Hello,
> I posted here last week regarding getting the right ISO to install
> Debian on my dual G5 PowerMac.
> I was pointed to rc5 and this worked fine when booted from cd. To get
> it to work though I had to select "install-power4 video=ofonly" on the
> first yaboot (?) screen.
> From there I was taken automatically through a few screens which were
> red, grey and blue - seemed to be using ncurses or something.
> Anyway, the only information it asked me for was the hostname and
> domain name of my new system.
> So far, so good.
> Eventually I got to the partitioning screen. After opting to erase the
> whole disk and then being asked what type of setup I would like the
> installer presented me with the following information of it's intended
> partitioning:
> #1  32.8 KB                      Apple
> #2  1.0 MB      boot   untitled
> #3  244.8 GB    ext3   untitled  /
> #4  6.2GB       ext3   swap      swap
> #2 had a downwards pointing arrow and a black face on the same line
> both #3 and #4 had a skull and crossbones on the same line
> It might be worth pointing out that my system has 2 disks. The first
> one is has OS X on and the second is used as storage space for OS X.
> For safety I unplugged the main system disk before booting with the
> Debian installation disk - just as a safety measure to stop me from
> removing my old system.
> The plan was to install Debian on the second disk, and once I was sure
> it worked as expected I would plug in the primary disk, copy across my
> important files, wipe and use fstab to mount as my new /home dir.
> So anyway, the installer told me everything was a success - ejected
> the CD and rebooted my system.
> When my system booted up the screens were all back for a good minute
> or so, a little animated icon of a question mark and a OS X system
> folder came up, the screen went black and I was then presented with
> the following screen (where I selected the "l" option):
> ---------------------------
> First Stage GNU/Linux Bootstrap
> Press l for GNU/Linux,
>       c for CDROM
> Stage 1 boot: l
> Loading second stage bootstrap...
> ---------------------------
> At this point, the same flashing question mark/folder icon came up.
> Nothing happened for a minute or so and then the screen reset it's
> self - presenting me with the same initial option.
> I tried this several times and nothing would get it past this screen -
> the only thing that seemed to work was inserting the Debian install
> disk and using the "c" option - but this just takes me back to step
> one.
> Does anyone know where I am going wrong? I reset my p-ram and it still
> doesn't work.
> I know OS X needs to 'bless' drives etc before this work - I do not
> understand this concept but  surely this is not relevant when I am
> installing Debian by it's self on the only blank disk the system can
> see?
> Thanks in advance for anyone who may be able to help me out.
> Regards,
> Noah

Reply to: