[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems booting into Debian installer on PowerMac G5


I posted here last week regarding getting the right ISO to install
Debian on my dual G5 PowerMac.

I was pointed to rc5 and this worked fine when booted from cd. To get
it to work though I had to select "install-power4 video=ofonly" on the
first yaboot (?) screen.

>From there I was taken automatically through a few screens which were
red, grey and blue - seemed to be using ncurses or something.

Anyway, the only information it asked me for was the hostname and
domain name of my new system.

So far, so good.

Eventually I got to the partitioning screen. After opting to erase the
whole disk and then being asked what type of setup I would like the
installer presented me with the following information of it's intended

#1  32.8 KB                      Apple
#2  1.0 MB      boot   untitled
#3  244.8 GB    ext3   untitled  /
#4  6.2GB       ext3   swap      swap

#2 had a downwards pointing arrow and a black face on the same line
both #3 and #4 had a skull and crossbones on the same line

It might be worth pointing out that my system has 2 disks. The first
one is has OS X on and the second is used as storage space for OS X.
For safety I unplugged the main system disk before booting with the
Debian installation disk - just as a safety measure to stop me from
removing my old system.

The plan was to install Debian on the second disk, and once I was sure
it worked as expected I would plug in the primary disk, copy across my
important files, wipe and use fstab to mount as my new /home dir.

So anyway, the installer told me everything was a success - ejected
the CD and rebooted my system.

When my system booted up the screens were all back for a good minute
or so, a little animated icon of a question mark and a OS X system
folder came up, the screen went black and I was then presented with
the following screen (where I selected the "l" option):

First Stage GNU/Linux Bootstrap

Press l for GNU/Linux,
      c for CDROM

Stage 1 boot: l

Loading second stage bootstrap...

At this point, the same flashing question mark/folder icon came up.
Nothing happened for a minute or so and then the screen reset it's
self - presenting me with the same initial option.

I tried this several times and nothing would get it past this screen -
the only thing that seemed to work was inserting the Debian install
disk and using the "c" option - but this just takes me back to step

Does anyone know where I am going wrong? I reset my p-ram and it still
doesn't work.

I know OS X needs to 'bless' drives etc before this work - I do not
understand this concept but  surely this is not relevant when I am
installing Debian by it's self on the only blank disk the system can

Thanks in advance for anyone who may be able to help me out.


Reply to: