[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: exim4 prone to break d-i, bug #297607



Hello Marc,

On Sunday 20 March 2005 15:44, Marc Haber wrote:
> This is a formal request to test whether the exim4 4.50-4.0
> downloadable from http://zg.debian.zugschlus.de/zg/pool/main/exim4 do
> any harm to d-i. Please test and inform me of any results.
>
> If I don't receive an answer by thursday 2005-03-24, I'll consider
> this as "everything is fine" and will proceed uploading to unstable.

A day late, but your request got a bit lost in the efforts to release 
RC3...

I tried integrating the new debs in the installation as much as possible 
by chrooting into the target system after base installation (debootstrap) 
and installing the debs with the noninteractive frontend.
This means that exim4 was configured after the reboot as normal during 
installation.

I noticed no problems during the installation or configuration in 2nd 
stage itself.


The only thing I did notice is that, if I run 'dpkg-reconfigure 
exim4-config' _after_ the installation is completed, "restarting MTA" 
takes a very long time (something like 30 seconds), but only the first 
time I do it. If I try to reproduce it later, the restart consistently 
only takes 4 or 5 seconds.
During recent normal installations from Sarge (on different archs), I've 
seen a similar problem: on the first shutdown after installation it takes 
a very long time to "stop MTA".
I have no idea what could cause this.


Tested on i386 using:
ii  exim4          4.50-4.0   metapackage to ease exim MTA (v4) installati
ii  exim4-base     4.50-4.0   support files for all exim MTA (v4) packages
ii  exim4-config   4.50-4.0   configuration for the exim MTA (v4)
ii  exim4-daemon-l 4.50-4.0   lightweight exim MTA (v4) daemon

Cheers,
FJP

Attachment: pgpvMxUZgKyIW.pgp
Description: PGP signature


Reply to: