[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: exim4 prone to break d-i, bug #297607

Hi Frans,

thanks for testing.

On Sat, Mar 26, 2005 at 12:13:45AM +0100, Frans Pop wrote:
> I tried integrating the new debs in the installation as much as possible 
> by chrooting into the target system after base installation (debootstrap) 
> and installing the debs with the noninteractive frontend.
> This means that exim4 was configured after the reboot as normal during 
> installation.
> I noticed no problems during the installation or configuration in 2nd 
> stage itself.


The original bug surfaced in joeyh's regression testing installations
and could be reproduced in a normal system.

> The only thing I did notice is that, if I run 'dpkg-reconfigure 
> exim4-config' _after_ the installation is completed, "restarting MTA" 
> takes a very long time (something like 30 seconds), but only the first 
> time I do it.

That sounds like a DNS issue. Exim tries to resolve its own hostname,
and if that cannot be done, it waits for a DNS timeout. Usual remedy
is making sure that the local hostname (hostname _and_ FQDN) is
resolvable via /etc/hosts, since for a new install the hostname is
unlikely to be available via DNS. See the second FAQ question in

> If I try to reproduce it later, the restart consistently 
> only takes 4 or 5 seconds.
> During recent normal installations from Sarge (on different archs), I've 
> seen a similar problem: on the first shutdown after installation it takes 
> a very long time to "stop MTA".

That's a new one. Can you try setting EX4DEBUG to a non-empty value
and see where the delay is happening?


Marc Haber         | "I don't trust Computers. They | Mailadresse im Header
Mannheim, Germany  |  lose things."    Winona Ryder | Fon: *49 621 72739834
Nordisch by Nature |  How to make an American Quilt | Fax: *49 621 72739835

Reply to: