[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#287021: debian-installer: Full build (d-i+udebs) fails using checkout of RC2

Hash: SHA1

Daniel Dickinson wrote:
|>> from d-i-rc2
|>> ./scripts/buildscript
|> This is only a convenience script for developers. It puts the generated
|> udebs in installer/build/localudebs/, where they should _not_ go for
|> a production build. The production build should fetch the udebs from
|> an apt-gettable repository.

Wait a sec - I think when I tried with the pool udebs it was with a
pre-compiled installer-i386 image not compiling from scratch.  I don't
think I have tried compiling only d-i.

<hangs head in shame>

My apologies.  I'll probably want to close this bug, unless compiling
d-i using apt-gettable udebs also doesn't work.

Perhaps, to avoid anyone else being so confused there could be a readme
or something in the scripts directory explaining that buildscript isn't
necessary unless you're modifying the udeb packages?  I think what
happened is that I assumed that because the installer-i386 + udebs
didn't work that I had to build the combo, which was, to my way of
thinking, confirmed by the presence of the packages directory, but
really that's not so.

I'm still a bit concerned by the fact that the d-i repository doesn't
build cleanly, but not as much as when I couldn't get a working
installer (assuming what I'm trying now works).
Version: GnuPG v1.2.4 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


Reply to: