[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#281907: Install report

Package: installation-reports


Debian-installer-version: 2004-11-14
uname -a: Linux phillipsa-old 2.6.8-1-386 #1 Thu Oct 7 02:21:16 EDT 2004 i686 GNU/Linux
Date: 2004-11-17
Method: Net install off of ftp.us.d.o using a netinst cd snapshot, through a local proxy
Machine: HP PL-Class workstation
Processor: 750 mHz PIII
Memory: 512
Root Device: /dev/sda2
Root Size/partition table:  
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          16      128488+  83  Linux (/boot)
/dev/sda2              17        1964    15647310   83  Linux (/)
/dev/sda3            1965        2213     2000092+   f  W95 Ext'd (LBA)
/dev/sda5            1965        2213     2000061   82  Linux swap

Output of lspci and lspci -n:
0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:13.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev 03)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a2)
0000:02:04.0 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev 26)0000:02:05.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] (rev 36)

0000:00:00.0 0600: 8086:7190 (rev 03)
0000:00:01.0 0604: 8086:7191 (rev 03)
0000:00:07.0 0601: 8086:7110 (rev 02)
0000:00:07.1 0101: 8086:7111 (rev 01)
0000:00:07.2 0c03: 8086:7112 (rev 01)
0000:00:07.3 0680: 8086:7113 (rev 02)
0000:00:13.0 0604: 1011:0024 (rev 03)
0000:01:00.0 0300: 10de:0181 (rev a2)
0000:02:04.0 0100: 1000:000f (rev 26)
0000:02:05.0 0200: 1022:2000 (rev 36)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


I get video corruption right after the preseed is downloaded.  This goes 
away after changing consoles.  Could be just this box, haven't tried 

I can't seem to get exim to configure if preseeded.  What I want is this, 
but I've tried other combinations with a similar non-result.  Sorry I 
can't describe this better.  I haven't had much luck configuring it by
hand (not using preseed) during the install either.

exim4-base      exim4/move_exim3_spool  boolean false
exim4-base      exim4/purge_spool       boolean false
exim4-config   exim4/dc_eximconfig_configtype  select  mail sent by smarthost; received via SMTP or fetchmail sent and received directly using SMTP
exim4-config    exim4/dc_local_interfaces       string
exim4-config    exim4/dc_minimaldns     boolean false
exim4-config    exim4/dc_noalias_regenerate     boolean false
exim4-config    exim4/dc_other_hostnames        string
exim4-config    exim4/dc_postmaster     string  root
exim4-config    exim4/dc_readhost       string
exim4-config    exim4/dc_relay_domains  string
exim4-config    exim4/dc_relay_nets     string
exim4-config    exim4/dc_smarthost      string  atlantic-exgate.atlantic.int.ec.gc.ca
exim4-config    exim4/exim3_upgrade     boolean true
exim4-config    exim4/hide_mailname     boolean false
exim4-config    exim4/use_split_config  boolean false

locale.gen doesn't get filled with the locale list I preseed.  This is 
really annoying because I need en_CA.*, en_US.* and fr_CA.* to work.
Maybe this isn't supposed to work?

locales locales/default_environment_locale      select  en_CA.UTF-8
locales locales/locales_to_be_generated multiselect     en_CA ISO-8859-1, en_CA.UTF-8 UTF-8, en_US ISO-8859-1, en_US.ISO-8859-15 ISO-8859-15, en_US.UTF-8 UTF-8, fr_CA ISO-8859-1, fr_CA.UTF-8 UTF-8

The following partman recipe should create /boot, / and swap as primary 
partitions, only the first two are created as primary.  This is forgivable
though. :)

d-i     partman-auto/expert_recipe      string Standard (/boot, / and swap) ::
128 128 256 ext3 $primary{ } $bootable{ } method{ format } format{ } use_filesystem{ } filesystem{ ext3 } mountpoint{ /boot } . 500 10000 1000000000 ext3 $primary{ } method{ format } format{ } use_filesystem{ } filesystem{ ext3 } mountpoint{ / } . 2048 2048 2252 linux-swap $primary{ } method{ swap } format{ } .

It would be nice if the preseed overwrote the already selected country, 
when grabbing it from a URL.

I'm using this to get the proxy into apt.conf.  Don't know if it's still 
needed, as I saw a bug related to this that was recently closed.

base-config     base-config/early_command       string test -f /etc/apt/apt.conf || echo 'Acquire::http::Proxy "http://whxs4.dart.ns.ec.gc.ca:3128";;' > /etc/apt/apt.conf

It would be nice to preseed additional APT sources and packages to install
so I don't have to use this late_command:

base-config     base-config/late_command        string echo >> /etc/apt/sources.list && echo 'deb http://phillipsa.dart.ns.ec.gc.ca/~andrew/debian-ec/apt unstable/' >> /etc/apt/sources.list && echo 'deb-src http://phillipsa.dart.ns.ec.gc.ca/~andrew/debian-ec/apt unstable/' >> /etc/apt/sources.list && apt-get update && apt-get --yes install ec-standard

Being able to add additional tasks through preseed would be nice to do
too. This would help with the above.  We have our own meta package for 
development and desktop machines which I am installing after setup.

If the URL in preseed/url isn't found, could a dialog ask for a different 
url to try?  Maybe ask for a URL if it's set to ask or blank?

Andrew Phillips
Informatics Service Branch
Environment Canada
(902) 426-6262

Reply to: