[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#274536: Debian Installer Pre RC2 on PARISC

On Saturday 02 October 2004 18:43, Joey Hess wrote:
> Peter Van Loock wrote:
> > When installing the base system, the installation seemed to stall on
> > 'Retrieving coreutils'. I waited for more than half an hour, but the
> > installer did not continue. On /dev/tty2, I could see that a 'cp'-command
> > was running.
> > When I tried to manually copy the file (coreutils) the shell also
> > blocked. The CD checked out OK. After I installed Debian using netboot, I
> > tried to copy this file from the same CD with the same CD-reader and this
> > worked without a problem.
> Many people have reported this kind of problem -- often this exact
> problem -- on hppa, but so far nobody has found out what causes a hang
> when reading from CD. I suppose it must be some sort of kernel problem;
> do you see a similar hang reading files from the CD using the system you
> installed by netboot?
> I think nobody else who has reported this problem has had a head on
> their hppa, so you're in a unique position to be able to debug this some
> in the other virtual terminal. Do you see anything interesting in dmesg
> when this happens? Could it be a DMA issue or something like that, or
> the wrong module loaded for the CD drive?
> (I'm glad you were able to get an install to work at all; afaik you're
> the first person to even do a hppa install with these images and the
> 2.4.27 kernell..)

On the netboot system I tried to copy lots of files from cdrom and the 'cp' 
command always hangs after some time. Sometimes the hang occurs after copying 
5 megabytes, sometimes after 7, sometimes after 11 ...
I used different cd's, one with only large files, one with only small files, 
one mixed. It appears that copying 2 large (about 5 megabyte) files is not 
possible, the second 'cp' hangs. When copying small files, sometimes hundreds 
of files get copied, but eventually the command hangs.

After mounting the cd, dmesg shows the usual message (iso9660 filesystem) and 
after that nothing else is added.
The driver for the cd is part of the kernel and not loaded as a module. In 
fact, no modules at all are loaded.

To confirm your suspicion about the kernel:
I installed the 2.6.8 kernel and with that the problem no longer exists. Every 
file gets copied successfully.

Reply to: