[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RC1 Report Installation Failed - Dell Dimension 8400

Hi folks,

Nice work on the new Debian installer. It worked great on an install to
a Dell with a PIII. Unfortunately, I'm having troubles getting it to
work with it on a newer Dell system that has an ICH6 SATA controller.
Here's my report:

Package: installation-reports

Debian-installer-version: rc1 - Aug 17, 2004 - http://www.debian.org/devel/debian-installer/
uname -a: Linux (none) 2.6.7-1-386 #1 Thu Jul 8 05:08:04 EDT 2004 i686 unknown
Date: Aug 17, 2004 1600EST
Method: Debian installer CD for i386

Machine: Dell Dimension 8400
Processor: Pentium 4 3.2Ghz with hyperthreading
Memory: 1Gb
Root Device: none
Root Size/partition table: 
      Can't view partition table
Output of lspci:
  There is no easy way to cut this info to my other workstation as my
  network card is not recognized (Broadcom NetXtreme 57xx).

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [E]
Partition hard drives:  [E]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


The network configuration fails due to it being a card with a
proprietary Broadcom NetXtreme 57xx chipset. Apparently Broadcom has
Linux drivers available. I only included this error for sake of
submitting a complete report.

My main problem is getting Debian to recognize the harddisk. Here's what
I've tried:

  * running the installer with 'linux26'
  * turning on "ATA only" in BIOS
  * turning on "SATA/PATA" combo mode (interestingly, the Libranet
    distro that supports SATA can see the drive in this mode)
  * turning on "AHCI mode" and using modprobe to load ata_piix and

The SATA controller is a ICH6 which is supposedly supported by the
latest ata_piix and libata. I'm not sure which version of these
libraries are being included with the installer but it's not working for
me at present.

I found a reference in the archives to how to get the installer to work
with the piix SATA controller[1]. I know how to compile a kernel but
don't know how to build an installer.  Any pointers or advice would be
appreciated. Let me know if I need to provide more details.


[1] http://lists.debian.org/debian-user/2004/07/msg03903.html

Knowmad Services Inc.

Reply to: