[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#264450: Installation Report

Package: installation-reports


Debian-installer-version: RC1
Method: Business-Card i386 ISO of RC1, installing base over http/proxy

Machine: IBM Thinkpad R51
Processor: Pentium M/1.5GHz
Memory: 512MB
Root Device: IC25N040ATMR04-0, ATA DISK drive
Root Size/partition table:  
    hda1  Primary   Linux ext3  4999.94    (Debian GNU/Linux)
    hda5  Logical   Linux ext2  1599.90    (Debian GNU/Hurd)
    hda9  Logical   Linux ext3  1599.90  /
    hda6  Logical   Linux ext3  27155.43   (data)
    hda7  Logical   Linux swap  1023.94  swap
    hda8  Logical   Linux ext2  3628.68    (data)

Output of lspci and lspci -n:

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [ ]
Reboot:                 [E]


1. It was previously suggested to rename the inital boot dialog, like
s/press Return to boot/press Return to install Debian/ or something

2. If I don't have a network cable plugged in, I get asked for an IP
address. It's possible to go back and then select 'No network
configuration' (or something), but having a button like 'Continue
without configuring the network' right there intially would be better.
Though that's probably i) not easy with debconf and ii) too late for
sarge anyway

3. As it wasn't immediatly obvious how to reformat a partition with
partman, I (perhaps foolishly) decided to delete and re-create /dev/hda6
(on which some other ext2 previously existed). However, the format
dialog and subsequent dialogs talked about /dev/hda9 being
created/written to, which made me a bit nervous. I finally figured out
that partman renumbered the devices (see above partition listing),
adding /dev/hda9 at the place of the former /dev/hda6 but calling it
/dev/hda9. Oh well, that was a bit unsuspected and I had to change the
/etc/fstab of my other partition to fix it. If it is possible the
partition numbering should be preserved IMHO.

4. I did not install Grub so I can't tell whether my GNU/Hurd partition
has been detected and included correctly, but I could test that another
time if needed.

5. On reboot, during the bootup sequence, the framebuffer switched to a
different font which yielded about twice as many lines on the console
(to my liking). However, as soon as base-config started (or perhaps
shortly before), the console became totally corrupted and scrambled. It
was possible to figure out that I was looking at the base-config screen
and changing virtual consoles worked, but I was not able to read

This was with the default 2.4 kernel. I later reinstalled passing
'kernel26' to d-i, which worked fine (though the console font stayed at
the intial size/number of lines)

6. I did not select any tasks in tasksel but rather did 'apt-get install
gnome' from the console (I don't like how both KDE and GNOME get
installed by the desktop task, but oh well). I also installed
x-window-system-core and before that discover, mdetect, read-edid.
Configuring X was mostly alright and I noticed that the synaptic
touchpad driver got loaded during it at one point. However, after
reboot, the driver did not get loaded and X failed to come up. I had to
manually add psmouse to /etc/modules.

That's about it. Needless to say I'm pretty proud of y'all :)


Install logs and other status info is available in

Reply to: