[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#256301: LVM in Beta 4




Sorry for being vague - this was my friend's comp and I have no access to it now.

We were trying to install Debian on what used to be a Slackware 9.1 root partition. In the Partitioning tool, I have chosen this partition up for a "format", fs type "ext3", mount at "/" , mount options "defaults", bootable "off". Then, I selected "done setting up the partition". At this point, the partitioning tool created ext3 on the partition, and I was back at the main list of all partitions. The links below the list said something like "help on partitioning" "guided partitioning" and "Set up LVM" . Even lower, at the lower left, there was a link to "go back" . But, there was *no* link to "continue" at the lower right. So, I thought I ought to set up this LVM thing now ( "help on partitionning" just got me to a help page, of course, and "guided partitioning got me to the list of partitionning tasks like "erase the whole /dev/hda" and "manually edit the partition table" - so, with no "continue", setting up LVM seemed like the only option I can go for at this moment )

But, no matter which option I went for when setting up that LVM, it kept spitting errors back at me, so there was really no way of making progress.

Finally, I went for d-i Beta 2. Everything went just like with Beta 4, with notable exception that this time there *was* a link to "continue" where previously there wasn't, and by choosing it rather than the LVM setup I was able to complete the installation flawlessly.

Like I said, I have no access to the logs, sorry. I've used the very same CD with the very same Beta 4 on my own comp, and installed Sarge on a former Knoppix 3.4 partition with no hassle.

Leszek


On Sun, 27 Jun 2004, Andrew Pollock wrote:

Date: Sun, 27 Jun 2004 16:29:08 +1000
From: Andrew Pollock <apollock@debian.org>
To: Leszek <leszek@serwer.3miasto.net>, 256301@bugs.debian.org
Subject: Re: Bug#256301: LVM in Beta 4

On Sat, Jun 26, 2004 at 01:37:54AM +0200, Leszek wrote:

Yesterday I've tried to use Beta 4 on my friend's comp; the problem was
that upon selecting a root partition for a format and setting up a swap
part. , it started bugging me about LVM. No matter which option I went for
( and I've tried everything ) it kept spitting out errors ( "no physical
partitions set up for LVM, cannot add group", etc )


Has this hard disk that you were installing onto ever had LVM used on it in
the past, with another distribution perhaps?

Just wondering if the disk had some physical volume signatures lying around
on it that didn't get blown away with a format or something...

regards

Andrew




Reply to: