[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#255984: minor comments on debian-installer

Package: installation-reports


Debian-installer-version: i386/beta4
uname -a: Linux blp 2.6.3-1-386 #2 Tue Feb 24 20:20:23 EST 2004 i686 GNU/Linux
Date: June 24, 2004
Method: Installed with `linux26' command line, booting from USB
        2.0 CD-RW with minimal CD-ROM, rest of install via e1000

Machine: ThinkPad X40 (model 2372-9EU)
Processor: Pentium M 1.2 GHz
Memory: 512 MB
Root Device: IDE 40 GB disk (HITACHI_DK13FA-40B)
Root Size/partition table:
        39 GB / ext3
        1 GB swap
Output of lspci and lspci -n:
0000:00:00.0 Host bridge: Intel Corp. 82852/855GM Host Bridge (rev 02)
0000:00:00.1 System peripheral: Intel Corp. 855GM/GME GMCH Memory I/O Control Registers (rev 02)
0000:00:00.3 System peripheral: Intel Corp. 855GM/GME GMCH Configuration Process Registers (rev 02)
0000:00:02.0 VGA compatible controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 02)
0000:00:02.1 Display controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 02)
0000:00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 01)
0000:00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 01)
0000:00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 01)
0000:00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI Controller (rev 01)
0000:00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 81)
0000:00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 01)
0000:00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage Controller (rev 01)
0000:00:1f.3 SMBus: Intel Corp. 82801DB/DBM (ICH4) SMBus Controller (rev 01)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 01)
0000:00:1f.6 Modem: Intel Corp. 82801DB (ICH4) AC'97 Modem Controller (rev 01)
0000:02:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 8d)
0000:02:00.1 Class 0805: Ricoh Co Ltd: Unknown device 0822 (rev 13)
0000:02:01.0 Ethernet controller: Intel Corp. 82541GI Gigabit Ethernet Controller
0000:02:02.0 Network controller: Intel Corp. Intel(R) PRO/Wireless 2200BG (rev 05)

0000:00:00.0 Class 0600: 8086:3580 (rev 02)
0000:00:00.1 Class 0880: 8086:3584 (rev 02)
0000:00:00.3 Class 0880: 8086:3585 (rev 02)
0000:00:02.0 Class 0300: 8086:3582 (rev 02)
0000:00:02.1 Class 0380: 8086:3582 (rev 02)
0000:00:1d.0 Class 0c03: 8086:24c2 (rev 01)
0000:00:1d.1 Class 0c03: 8086:24c4 (rev 01)
0000:00:1d.2 Class 0c03: 8086:24c7 (rev 01)
0000:00:1d.7 Class 0c03: 8086:24cd (rev 01)
0000:00:1e.0 Class 0604: 8086:2448 (rev 81)
0000:00:1f.0 Class 0601: 8086:24cc (rev 01)
0000:00:1f.1 Class 0101: 8086:24ca (rev 01)
0000:00:1f.3 Class 0c05: 8086:24c3 (rev 01)
0000:00:1f.5 Class 0401: 8086:24c5 (rev 01)
0000:00:1f.6 Class 0703: 8086:24c6 (rev 01)
0000:02:00.0 Class 0607: 1180:0476 (rev 8d)
0000:02:00.1 Class 0805: 1180:0822 (rev 13)
0000:02:01.0 Class 0200: 8086:1077
0000:02:02.0 Class 0280: 8086:4220 (rev 05)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


Configuring the network via DHCP only seemed to happen properly
if it worked the first time.  That is, if, say, the network cable
was disconnected at first and I connected it then told it to
retry, it appeared to not bother retrying and simply proceeded
immediately to the next screen.

When I used `linux26' without any boot options, switching from
console 1 and back during install corrupted the screen to the
extent that I couldn't complete the install and had to restart.
Using `video=vga16:off vga=771' fixed the problem, but then the
background color on console 1 changed from blue at boot time to
red after I changed consoles (!).

The initial reboot ran ext3 recovery, suggesting that the root
partition didn't get cleanly unmounted by the install.

In general: this installer is a big improvement on the previous
one.  Great job!
"The sound of peacocks being shredded can't possibly be
 any worse than the sound of peacocks not being shredded."
Tanuki the Raccoon-dog in the Monastery

Reply to: