[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#255984: marked as done (dhcp retry can be confusing)

Your message dated Tue, 29 Jun 2004 14:17:05 -0400
with message-id <E1BfNAH-00006V-00@newraff.debian.org>
and subject line Bug#255984: fixed in netcfg 0.71
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 24 Jun 2004 05:50:07 +0000
>From blp@benpfaff.org Wed Jun 23 22:50:07 2004
Return-path: <blp@benpfaff.org>
Received: from smtp-roam.stanford.edu [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BdN7f-00047F-00; Wed, 23 Jun 2004 22:50:07 -0700
Received: from blp.benpfaff.org (c-24-6-66-193.client.comcast.net [])
	(authenticated bits=0)
	by smtp-roam.Stanford.EDU (8.12.11/8.12.11) with ESMTP id i5O5o55C017620
	(version=TLSv1/SSLv3 cipher=EDH-RSA-DES-CBC3-SHA bits=168 verify=NOT)
	for <submit@bugs.debian.org>; Wed, 23 Jun 2004 22:50:06 -0700
Received: from blp by blp.benpfaff.org with local (Exim 3.35 #1 (Debian))
	id 1BdN7Z-0002MR-00
	for <submit@bugs.debian.org>; Wed, 23 Jun 2004 22:50:01 -0700
To: submit@bugs.debian.org
Subject: minor comments on debian-installer
Reply-To: blp@cs.stanford.edu
From: Ben Pfaff <blp@cs.stanford.edu>
Date: Wed, 23 Jun 2004 22:50:00 -0700
Message-ID: <[🔎] 871xk5ec8n.fsf@blp.benpfaff.org>
User-Agent: Gnus/5.1006 (Gnus v5.10.6) Emacs/21.3 (gnu/linux)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Sender: Ben Pfaff <blp@benpfaff.org>
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: installation-reports


Debian-installer-version: i386/beta4
uname -a: Linux blp 2.6.3-1-386 #2 Tue Feb 24 20:20:23 EST 2004 i686 GNU/Linux
Date: June 24, 2004
Method: Installed with `linux26' command line, booting from USB
        2.0 CD-RW with minimal CD-ROM, rest of install via e1000

Machine: ThinkPad X40 (model 2372-9EU)
Processor: Pentium M 1.2 GHz
Memory: 512 MB
Root Device: IDE 40 GB disk (HITACHI_DK13FA-40B)
Root Size/partition table:
        39 GB / ext3
        1 GB swap
Output of lspci and lspci -n:
0000:00:00.0 Host bridge: Intel Corp. 82852/855GM Host Bridge (rev 02)
0000:00:00.1 System peripheral: Intel Corp. 855GM/GME GMCH Memory I/O Control Registers (rev 02)
0000:00:00.3 System peripheral: Intel Corp. 855GM/GME GMCH Configuration Process Registers (rev 02)
0000:00:02.0 VGA compatible controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 02)
0000:00:02.1 Display controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 02)
0000:00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 01)
0000:00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 01)
0000:00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 01)
0000:00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI Controller (rev 01)
0000:00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 81)
0000:00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 01)
0000:00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage Controller (rev 01)
0000:00:1f.3 SMBus: Intel Corp. 82801DB/DBM (ICH4) SMBus Controller (rev 01)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 01)
0000:00:1f.6 Modem: Intel Corp. 82801DB (ICH4) AC'97 Modem Controller (rev 01)
0000:02:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 8d)
0000:02:00.1 Class 0805: Ricoh Co Ltd: Unknown device 0822 (rev 13)
0000:02:01.0 Ethernet controller: Intel Corp. 82541GI Gigabit Ethernet Controller
0000:02:02.0 Network controller: Intel Corp. Intel(R) PRO/Wireless 2200BG (rev 05)

0000:00:00.0 Class 0600: 8086:3580 (rev 02)
0000:00:00.1 Class 0880: 8086:3584 (rev 02)
0000:00:00.3 Class 0880: 8086:3585 (rev 02)
0000:00:02.0 Class 0300: 8086:3582 (rev 02)
0000:00:02.1 Class 0380: 8086:3582 (rev 02)
0000:00:1d.0 Class 0c03: 8086:24c2 (rev 01)
0000:00:1d.1 Class 0c03: 8086:24c4 (rev 01)
0000:00:1d.2 Class 0c03: 8086:24c7 (rev 01)
0000:00:1d.7 Class 0c03: 8086:24cd (rev 01)
0000:00:1e.0 Class 0604: 8086:2448 (rev 81)
0000:00:1f.0 Class 0601: 8086:24cc (rev 01)
0000:00:1f.1 Class 0101: 8086:24ca (rev 01)
0000:00:1f.3 Class 0c05: 8086:24c3 (rev 01)
0000:00:1f.5 Class 0401: 8086:24c5 (rev 01)
0000:00:1f.6 Class 0703: 8086:24c6 (rev 01)
0000:02:00.0 Class 0607: 1180:0476 (rev 8d)
0000:02:00.1 Class 0805: 1180:0822 (rev 13)
0000:02:01.0 Class 0200: 8086:1077
0000:02:02.0 Class 0280: 8086:4220 (rev 05)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


Configuring the network via DHCP only seemed to happen properly
if it worked the first time.  That is, if, say, the network cable
was disconnected at first and I connected it then told it to
retry, it appeared to not bother retrying and simply proceeded
immediately to the next screen.

When I used `linux26' without any boot options, switching from
console 1 and back during install corrupted the screen to the
extent that I couldn't complete the install and had to restart.
Using `video=vga16:off vga=771' fixed the problem, but then the
background color on console 1 changed from blue at boot time to
red after I changed consoles (!).

The initial reboot ran ext3 recovery, suggesting that the root
partition didn't get cleanly unmounted by the install.

In general: this installer is a big improvement on the previous
one.  Great job!
"The sound of peacocks being shredded can't possibly be
 any worse than the sound of peacocks not being shredded."
Tanuki the Raccoon-dog in the Monastery

Received: (at 255984-close) by bugs.debian.org; 29 Jun 2004 18:23:01 +0000
>From katie@ftp-master.debian.org Tue Jun 29 11:23:01 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BfNG1-0004OY-00; Tue, 29 Jun 2004 11:23:01 -0700
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1BfNAH-00006V-00; Tue, 29 Jun 2004 14:17:05 -0400
From: Joshua Kwan <joshk@triplehelix.org>
To: 255984-close@bugs.debian.org
X-Katie: $Revision: 1.51 $
Subject: Bug#255984: fixed in netcfg 0.71
Message-Id: <E1BfNAH-00006V-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Tue, 29 Jun 2004 14:17:05 -0400
Delivered-To: 255984-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Score: 8

Source: netcfg
Source-Version: 0.71

We believe that the bug you reported is fixed in the latest version of
netcfg, which is due to be installed in the Debian FTP archive:

  to pool/main/n/netcfg/netcfg-dhcp_0.71_i386.udeb
  to pool/main/n/netcfg/netcfg-static_0.71_i386.udeb
  to pool/main/n/netcfg/netcfg_0.71.dsc
  to pool/main/n/netcfg/netcfg_0.71.tar.gz
  to pool/main/n/netcfg/netcfg_0.71_i386.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 255984@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joshua Kwan <joshk@triplehelix.org> (supplier of updated netcfg package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Tue, 29 Jun 2004 10:51:48 -0700
Source: netcfg
Binary: netcfg-static netcfg-dhcp netcfg
Architecture: source i386
Version: 0.71
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joshua Kwan <joshk@triplehelix.org>
 netcfg     - Configure the network (udeb)
 netcfg-dhcp - Configure the network via DHCP (udeb)
 netcfg-static - Configure a static network (udeb)
Closes: 239284 239591 243543 248071 253543 255185 255187 255984
 netcfg (0.71) unstable; urgency=low
   * Joshua Kwan
     - Remove XSIisms in dhclient-script.
     - Evaluate argv[0] after calling basename on it so that we can strcmp it
       against "ptom". It somehow didn't happen in the internal dhclient-script
       context, but appeared during testing in the shell.
     - Add Thomas Hood to Uploaders.
     - Re-enable broadcast stuff in dhclient-script, fixing a Sparc (at least)
     - Remove kill_dhcp_client prototype from netcfg.h because it's now static.
     - Change newline + a space to just a newline to end some disable_dhcp
     - Warn if there's no default route available after getting a DHCP lease.
       (Closes: #253543)
     - Don't add 'auto' or hotplug mapping lines for 16-bit PCMCIA devices.
       (Closes: #248071, #239284)
     - Add a missing fclose in iface_is_hotpluggable.
   * Christian Perrier
     - netcfg-dhcp.templates
       Some rewrite for being clearer, possibly. Run debconf-updatepo
   * Thomas Hood
     - Change interfaces options that use underscore to hyphens. No loss
       of functionality. (Closes: #255185)
     - *.c:
       + Test for NULL pointers before using empty_str()
     - netcfg.c, netcfg-dhcp.c, netcfg-static.c
       + Handle the case where there are no interfaces.  Just ask for a
         hostname and write basic /etc/network/interfaces and /etc/hosts
         files.  (Closes: #243543)
     - netcfg-common.c:
       + netcfg_get_interface(): Don't exit if there are no interfaces.
         Instead just return with variables set to 0.
       + netcfg_write_common(): write basic /etc/network/interfaces and
         /etc/hosts files even if the ipaddress is 0.
     - static.c:
       + Add resolvconf support (Closes: #255187)
       + Add comments to /e/n/i about which packages implement which options
     - dhcp.c
       + Add comments to /e/n/i about which packages implement which options
       + Fix race to dhcp_exit_status after dhcp_running set to 0.
       + Count iterations in the polling loop instead of checking the time()
       + Use waitpid(dhcp_pid,,) instead of wait() to get child status
         since we don't want the status of, e.g., killall.sh
       + Eliminate use of dhcp_running and use (dhcp_pid>0) in its place
       + Eliminate some unnecessary calls to kill_dhcp_client()
       + Mark local variables with "static"
       + Eliminate use of quit_after_hostname by creating HOSTNAME_SANS_NETWORK
       + Use DHCP hostname as the default hostname if no hostname is set
         (Closes: #239591)
       + Write hostname provided to the DHCP client in order to get a lease
         on the "hostname" option line for the interface in /e/n/i
       + If the user backs up from netcfg/get_hostname, go to retry question
       + Wait at least two seconds for DHCP client to exit  (Closes: #255984)
       + Clean up code
         . Always use spaces for indentation
         . Improve comments
         . Reorder state machine states
         . Move some functions around
     - netcfg-dhcp.templates:
       + More updates
       + Run debconf-updatepo again
    * Updated translations:
     - German (de.po) by Alwin Meschede
     - Greek (el.po) by George Papamichelakis
     - Basque (eu.po) by Piarres Beobide Egaña
     - Hebrew (he.po) by Lior Kaplan
     - Japanese (ja.po) by Kenshi Muto
     - Dutch (nl.po) by Bart Cornelis
     - Portuguese (Brazil) (pt_BR.po) by André Luís Lopes
     - Turkish (tr.po) by Osman Yüksel
     - Ukrainian (uk.po) by Eugeniy Meshcheryakov
     - Simplified Chinese (zh_CN.po) by Carlos Z.F. Liu
 58b6257cce0d230e75f7ee2467ad754f 1507 debian-installer optional netcfg_0.71.dsc
 dc677a67933085b2cf262d62b0e63678 171100 debian-installer optional netcfg_0.71.tar.gz
 14189789f5cd2325ad21ae2c383fa823 130144 debian-installer optional netcfg_0.71_i386.udeb
 228cc299b197be17d2ffb37267fccc51 99072 debian-installer optional netcfg-dhcp_0.71_i386.udeb
 84de5825143cfe34c9c8fbba5a0cff44 110098 debian-installer optional netcfg-static_0.71_i386.udeb
package-type: udeb

Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: