[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#253033: installation-reports

Package: installation-reports

Debian-installer-version: not sure; from isolinux/f1.txt: "This is a Debian installation CD-ROM, built on 20040429."

uname -a: Linux server1 2.6.6-1-386 #1 Wed May 12 13:19:06 EST 2004 i686 GNU/Linux
Date: June 4, 2004
Method: installed from a CD-ROM burned from sarge-i386-1.iso assembled from http://cdimage.debian.org/pub/cdimage-testing/cd/jigdo-area/i386/sarge-i386-1.jigdo on June4, 2004

Machine: Pentium PIII on Intel 440BX
Processor: Pentium PIII
Memory: 128 MB SDRAM
Root Device: IDE hde (attached to add-on pdc202xx card)
Root Size/partition table:
server1:/# fdisk -l

Disk /dev/hde: 20.5 GB, 20547841536 bytes
255 heads, 63 sectors/track, 2498 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hde1   *           1          12       96358+  83  Linux  <-- /boot
/dev/hde2              13          43      249007+  83  Linux  <-- swap
/dev/hde3              44        2498    19719787+  83  Linux  <-- /

Output of lspci:
server1:/# lspci
0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03) 0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:09.0 Ethernet controller: Macronix, Inc. [MXIC] MX987x5 (rev 25)
0000:00:0c.0 Unknown mass storage controller: Promise Technology, Inc. 20267 (rev 02) 0000:01:00.0 VGA compatible controller: Trident Microsystems 3DImage 9850 (rev f3)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Multiple attempts -- at least 5. Tried linux, expert, linux26, expert26. Never offered the opportunity to configure network. Tried with 2 different NICs - a common Macronix, and an Intel e100. Installer seemed to see NIC -- module was loaded in alt console, but never started network configuration. Selecting network module in expert mode resulted in message to the effect "requested module not available". Workaround: after first boot, load module & configure network manually in alt console, return to package selection to select mirror.

Additional point:

Promise add-on ATA-100 card has taken interrupt 10, forcing network interface alternatively to 5 or to share interrupt 11 with USB.

server1:/# cat /proc/interrupts
  0:    1708005          XT-PIC  timer
  1:       1750          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  8:          4          XT-PIC  rtc
 10:       4867          XT-PIC  ide2
 11:       1225          XT-PIC  uhci_hcd, eth0
 14:        110          XT-PIC  ide0
NMI:          0
LOC:    1707942
ERR:          0
MIS:          0

Reply to: