[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#248047: Cobalt install

* christian mock <cm@tahina.priv.at> [2004-05-20 19:05]:
> installation report revealing a show-stopper:

The show-stopper is the network configuration, right?

> - it asks for an IP address and other network config data -- it should
>   just use the data it already has gotten via DHCP (ISTR the woody
>   netinst does just that)

unstable has a new netcfg package which is quite broken.  This also
explains the wrong IP address and /etc/network/interfaces not being
updated.  This netcfg probably won't make it to rc1 - the only reason
I wanted you to test unstable is to see if the ext2 revision 0 boot
partition works.

The problem here why DHCP is not started automatically is that the new
netcfg looks for a MII signal to see whether you're connectec to the
network; but for some reason it fails (the Cobalt can do MII).

> - it mis-configures the IP address -- I entered
>   "", but it ifconfig's Yes, I tried that
>   twice to make sure I didn't mistype the address :-) 

I'll forward this to the netcfg maintainer.  Can you check in
/var/log/debian-installer/package-versions which version of netcfg was

But if you did the install today, I guess it was 0.64.  Yeah, must be

> - The first time when asking for a debian mirror, it didn't ask if I
>   wanted http or ftp; the second time around, it does. Also, it

This is normal / a known bug.  I think the mirror list should include
whether the mirror does http or ftp.  And when you enter a custom
mirror, it should always ask you (I filed a bug about this a long time

> - in the "load installer components" screen, I selected "continue",
>   all of the offered modules were unselected by default and left that
>   way.

That's okay because those modules are only optional modules; those
which are required were not shown.  Did the menu not make that clear?

> - partitioning: the disk already had partitions and file systems from
>   the last test; choose "partitioning method: erase entire disk".
>   |           >      #1 primary   98.6 MB B f ext2r0     /boot  #           |   
>   |           >      #2 primary   19.8 GB   f ext3       /      #           |   
>   |           >      #5 logical  518.1 MB   f swap       swap   #           |   
> - reboot works well, machine comes up fine.

Good, so it works!

> [many hours later... boy, is that box sloooow!]

Really?  It takes about 45 minutes here (fast network connection).
How long does it take for you (roughly)?

> - in base-config, there's no visual indication of the active button --
>   both look exactely like this (i.e. no bold or inverse or stuff,
>   cursor is somewhere else):
>  . Is the hardware clock set to GMT?                                         .  
>  .                    <Yes>                       <No>                       .  

Did you do the installation without a colour-enabled terminal program?

> - line editing characters (^U, ^A, ...) don't work in text entry fields.

Do you know if that worked before?

> I'll be mighty busy the next two weeks, and maybe I'll not have a
> RAQ available afterwards... maybe I could do another test install
> next sunday.

Ah, thanks for testing.  I'll try to get the ext2 revision 0 program
pushed into testing before Sunday, so if you could do an installation
of "testing" on Sunday this would be appreciated.  This should work
100% without any problems, and if there are any, we have to fix them
for rc1.

Martin Michlmayr

Reply to: