[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#241228: Oldworld from floppy, installing the kernel fails



Package: installation-reports

Debian-installer-version: floppy images from 
http://sprite.fr.eu.org/d-i-oldworld/floppy/ 
uname -a: Linux version 2.4.25-powerpc-small #1 ven mar 19 21:19:23 CET 2004 
ppc GNU/Linux
Date: 2004-03-31, around noon. (and yesterday)
Method: boot-floopies, which were boot.img, root.img, net-drivers.img I tried 
to install sarge and used ftp.de.debian.org as mirror. No proxy was used. 

Machine: PowerMacintosh 4400/200
processor       : 0
cpu             : 603ev
clock           : 200MHz
revision        : 2.1
bogomips        : 11.89
zero pages      : total 0 (0Kb) current: 0 (0Kb) hits: 0/96 (0%)
machine         : Power Macintosh
motherboard     : AAPL,e826 MacRISC
L2 cache        : 256K unified
memory          : 48MB
pmac-generation : OldWorld
Root Device: ide, /dev/hda
Root Size/partition table: 
/dev/hda
        #                    type name                length   base    ( size 
)  system
/dev/hda1     Apple_partition_map Apple                   63 @ 1       ( 
31.5k)  Partition map
/dev/hda2         Apple_Bootstrap untitled           2320313 @ 64      (  
1.1G)  NewWorld bootblock
/dev/hda3         Apple_UNIX_SVR2 swap                183495 @ 2320377 ( 
89.6M)  Linux swap

Block size=512, Number of Blocks=2503872
DeviceType=0x0, DeviceId=0x0

Output of lspci:
00:0b.0 Host bridge: Apple Computer Inc. Bandit PowerPC host bridge (rev 03)
00:0e.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 
74)
00:10.0 Class ff00: Apple Computer Inc. O'Hare I/O (rev 01)
00:11.0 VGA compatible controller: ATI Technologies Inc 264VT [Mach64 VT] (rev 
40)


Base System Installation Checklist:

Initial boot worked:    [o]
Configure network HW:   [o]
Config network:         [o]
Detect CD:              [o] (only when using cd-drivers.img instead of 
net-drivers.img)
Load installer modules: [o ]
Detect hard drives:     [o]
Partition hard drives:  [o]
Create file systems:    [o]
Mount partitions:       [o]
Install base system:    [e]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Comments/Problems:

First of all: the new debian installer (and sarge) rocks! this machine is too 
slow but I also tried d-i on an athlon1600, whoowhoo. Great work everyone 
involved!!

Yesterday I was pointed to these floppy images 
http://sprite.fr.eu.org/d-i-oldworld/floppy/, (how) are they different from 
the ones avaible here: 
http://people.debian.org/~luther/debian-installer/daily-powerpc-built/current/powerpc-small/floppy/ 
?

Installing sarge yesterday failed with the adduser-package not avaible for 
download. (which wasn't true, obviously.) after that the installer wasn't 
able to download a release-file, too. until I reconfigured the network (with 
dhcp as before)). very strange.

So I tried to install sarge from cd (with cd-drivers.img) and also unstable 
via network, the results were the same as trying to install sarge from net 
(with net-drivers.img) today:

Base systems installs ok until it reaches around 70% then it fails complaining 
that I try to install an initrd-kernel....
---begin_bla-----------------
You are attempting to install an initrd kernel image (version 
2.4.25-powerpc-small)
This will not work unless you have configured your boot loader to use
initrd. (An initrd image is a kernel image that expects to use an INITial
Ram Disk to mount a minimal root file system into RAM and use that for
booting).


I repeat, You need to configure your boot loader -- please read your
bootloader documentation for details on how to add initrd images.

If you have already done so, and you wish to get rid of this message,
please put
  `do_initrd = Yes'
in /etc/kernel-img.conf. Note that this is optional, but if you do not,
you'll continue to see this message whenever you install a kernel
image using initrd.
Do you want to stop now? [Y/n]n
---end_bla-----------------

So I installed kernel-images manuelly, called "quikconfig", edited 
/etc/quik.conf so it looks like this:

---begin_bla-----------------
#root=/dev/hda2
# Generated by quikconfig
# (C) 1998 Matt McLean <keys@yikes.com>
# partition=3
# map=/boot/map
timeout=20
image=/boot/vmlinux-2.4.25-powerpc-small
label=Linux
read-only
append = " initrd=/boot/initrd.img-2.4.25-powerpc-small  video=atyfb"
# don't know & care now, if the video-option is neccessary here...
---end_bla-----------------

and set openfirmware like this:

nvsetenv boot-device ata/ata-disk@0:0
nvsetenv input-device    kbd
nvsetenv output-device   screen
nvsetenv boot-file "/boot/vmlinux-2.4.25-powerpc-small video=atyfb 
initrd=/boot/initrd.img-2.4.25-powerpc-small"

Booting the systems gets the following error: "VFS: Cannot open root device "" 
or 08:01"
bla bla rebooting in 180seconds.

(These settings do work on woody, but I only used them without "initrd=" and 
with "root="...)


regards,
	Holger




Reply to: