[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#241228: Oldworld from floppy, installing the kernel fails

On Wed, Mar 31, 2004 at 03:01:04PM +0200, Holger Levsen wrote:
> Package: installation-reports
> Comments/Problems:
> First of all: the new debian installer (and sarge) rocks! this machine is too 
> slow but I also tried d-i on an athlon1600, whoowhoo. Great work everyone 
> involved!!
> Yesterday I was pointed to these floppy images 
> http://sprite.fr.eu.org/d-i-oldworld/floppy/, (how) are they different from 
> the ones avaible here: 
> http://people.debian.org/~luther/debian-installer/daily-powerpc-built/current/powerpc-small/floppy/ 

Well, the previous were built by Jeremie Koenig, while the later were
built by me :) I don't know what date the previous were built, but the
later are daily builds, so they should be more uptodate.

> Installing sarge yesterday failed with the adduser-package not avaible for 
> download. (which wasn't true, obviously.) after that the installer wasn't 
> able to download a release-file, too. until I reconfigured the network (with 
> dhcp as before)). very strange.
> So I tried to install sarge from cd (with cd-drivers.img) and also unstable 
> via network, the results were the same as trying to install sarge from net 
> (with net-drivers.img) today:
> Base systems installs ok until it reaches around 70% then it fails complaining 
> that I try to install an initrd-kernel....
> ---begin_bla-----------------
> You are attempting to install an initrd kernel image (version 
> 2.4.25-powerpc-small)
> This will not work unless you have configured your boot loader to use
> initrd. (An initrd image is a kernel image that expects to use an INITial
> Ram Disk to mount a minimal root file system into RAM and use that for
> booting).

Oh, damnit, clue-less kernel-package has hit again.

> I repeat, You need to configure your boot loader -- please read your
> bootloader documentation for details on how to add initrd images.
> If you have already done so, and you wish to get rid of this message,
> please put
>   `do_initrd = Yes'
> in /etc/kernel-img.conf. Note that this is optional, but if you do not,
> you'll continue to see this message whenever you install a kernel
> image using initrd.
> Do you want to stop now? [Y/n]n
> ---end_bla-----------------

Does using testing instead of unstable change a thing for this.

> So I installed kernel-images manuelly, called "quikconfig", edited 
> /etc/quik.conf so it looks like this:
> ---begin_bla-----------------
> #root=/dev/hda2
> # Generated by quikconfig
> # (C) 1998 Matt McLean <keys@yikes.com>
> # partition=3
> # map=/boot/map
> timeout=20
> image=/boot/vmlinux-2.4.25-powerpc-small
> label=Linux
> read-only
> append = " initrd=/boot/initrd.img-2.4.25-powerpc-small  video=atyfb"
> # don't know & care now, if the video-option is neccessary here...
> ---end_bla-----------------
> and set openfirmware like this:
> nvsetenv boot-device ata/ata-disk@0:0
> nvsetenv input-device    kbd
> nvsetenv output-device   screen
> nvsetenv boot-file "/boot/vmlinux-2.4.25-powerpc-small video=atyfb 
> initrd=/boot/initrd.img-2.4.25-powerpc-small"
> Booting the systems gets the following error: "VFS: Cannot open root device "" 
> or 08:01"
> bla bla rebooting in 180seconds.
> (These settings do work on woody, but I only used them without "initrd=" and 
> with "root="...)

Then do so here too. The message is wrong naturally, and you should boot
with root=/dev/hda<whatever you choose>.


Sven Luther

Reply to: