[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#241231: DECstation 5000/133 (mipsel) install with some problems

Package: installation-reports


Debian-installer-version: daily r3k-kn02/boot.img snapshot, 2003-03-30
uname -a: Linux decstation 2.4.19-r3k-kn02 #1 Tue Dec 16 08:42:55 UTC 2003 mips GNU/Linux
Method: TFTP via network; CD boot failed
Machine: DECstation 5000/133
Processor: R3K
Memory: 32 MB
Root Device: SCSI
Output of lspci: no PCI

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O] TFTP worked, CD-ROM failed
Configure network HW:   [O]
Config network:         [O] almost resulted in timeout
Detect CD:              [ ]
Load installer modules: [O] tries to load (non-existing) IDE modules
Detect hard drives:     [O]
Partition hard drives:  [O] some partman LVM problems
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [ ] wasn't done for some reason
Reboot:                 [O]


I first tried an installation via TFTP.  I started it like this, but there
for only those 4 lines of output:

>>boot 3/tftp/boot.img-r3k
t-rex-loader V0.1 Copyright 2003  Thiemo Seufer <seufer@csv.ica.uni-stuttgart.de>
Loading ... ok
This is a DECstation 5000/1xx

Kernel booted correctly, but didn't use the serial console... so I tried
again with:

>>boot 3/tftp/boot.img-r3k console=ttyS2

And this worked.  This should be documented better.

I first chose the language, but it didn't ask me for the country but
instead dropped me into main menu on "Select a keyboard layout".   Maybe
this was because of 32 MB memory only, but I didn't get a message about
low-mem installs.

"Select a keyboard layout": doesn't do anything (I didn't have a
keyboard conncted, but anyway).

Hardware detection: it tries to load all kind of IDE modules, but then
skips it because the modules are not available.  In fact, it also shows me
a menu and the IDE modules are selected by default?  Why?  Surely this
shouldn't be selected by default on this machine.  I'm talking about this:
   Modules to load: 
                  [*] floppy (Linux Floppy)
                  [*] ide-mod (Linux IDE driver)
                  [*] ide-probe-mod (Linux IDE probe driver)
                  [*] ide-detect (Linux IDE detection)
                  [*] ide-floppy (Linux IDE floppy)
                  [*] ide-disk (Linux ATA DISK)
                  [*] ide-cd (Linux ATAPI CD-ROM)
                  [*] isofs (Linux ISO 9660 filesystem)
These should not be on by default, at least not on this machine.

DHCP: normally (on installs on other machines), I get a DHCP response at
20%.  Here, the first thing I saw was 40%, and it got an IP at 80%...
perhaps it should wait longer on slow machines?

partman: it feels very slow, it asks many questions: many windows are
opened which is slow on a 9600 serial console.  I think it's possible to
run the DECstation at a higher speed.  How can this be configured and can
this be documented?  Also, it would be good if partman would not ask that
many questions and open so many new windows.

In partman, I first set up a root partition, swap and home, and one for
LVM.  When I went to "configure LVM", it formated all the partitions, but
then went back to the "main menu on "Select a keyboard layout".  When I
start partman again, I see "Starting up the partitioner" but then it just
goes back to the main menu.  Ugh, everything lost after so much time.  How
can I find out what went wrong?

Anyway, the partition table was written, so I just went ahead with
"Configure and mount partitions".  Again, /etc/fstab was empty.

The install was fine, but no boot loader was installed!  I only got
"Continue without boot loader".  I don't know why delo-installer was not
installed at all!

Also, kernel-image-2.4.19-r4k-kn04 was installed instead of the -r3k-kn02
variant.  From looking at the code, I have no idea why.

Also, no ttyS2 entry was added to /etc/inittab

After the last screen when it tells me it is going to reboot, the screen
was not cleared and all sort of funny characters appeared (some cannot be
seen here):

S± SIGKILL   .ng the installation                      
P    ±  ., check that there are no       
KN02-BA V5.7    (PC: 08019404, SP: 0812°8)in the tray.  If you made 

Would it be possible to clear the screen or do something?

Hmm, most docs say you should boot from 3/rz0... but it's 3/rz1 here.  It
would be nice to add some notes to the docs how to figure out the root
device.  And ideally delo-installer should tell the user as well.

>>boot 3/rz0
?IO:  3/rz0  (bb rd)
>>boot 3/rz1
delo V0.8
Copyright 2000-2002 Florian Lohoff <flo@rfc822.org>
Copyright 2003 Thiemo Seufer <seufer@csv.ica.uni-stuttgart.de>
Loading /etc/delo.conf . ok

During boot, I get:
    sed: can't read MOTD: No such file or directory
I have no idea where this is from.

I also get:
    INIT: open(/dev/console): Input/output error

I also get:
    decstation login: root
    Login incorrect
root cannot log in because ttyS2 is not listed in /etc/securetty.  I think
I'll file a bug about this on shadow.

OK, another problem.... dhclient shows all sorts of funny things when the
network is not connected:

Please contribute if you find this software useful.
For info, please visit http://www.isc.org/dhcp-contrib.html

Listening on LPF/eth0/08:0e:2b:34tee:4h
ten0: gCan   LrF/eth0/0r:00:2b:34:ee:4ier Lnosng on t Sock
DHCPREQUEST on eth0 to port 67
DHCeth0: ST oC eth0aro 255.255.2ri.2er portLo7
LostDISCOVEt onh0th: to 25 .25Ca255.255 prrt 67 ier rval 4
DHCPDISCOVER eth0:h0  o 255.C55.255.255 porarrieinterval 5
r Lost
DHCeth0COVER :n et Carr 255.255.255i25erpor L67 intervos t

DHCetISCOVER hn0:th0  o 255.255.Ca5.rr5 port 67 inierer  8
DHCeDISCOVEtho0:eth0  o 255.Ca5.2rrier  port 67Lontestal
DHCPDISetVh0: C eth0 to 255.a55rri5.255 pert 67 interval
DHCetISCOVERhon0:th Carr255.i55.255.e55rport 67 interva L1o
DHCPDeSCOthR o0:eth0  o 255.C55.ar5.rie port 67 r tLosalt8

No DHCPOFFERS received.
Trying recorded lease
PING eth0: Carrier Lost

Trying to boot from CD:

The docs should mention how to find out the right boot command...

>>cnfg 3
 3: KN02-BA  DEC      V5.7j    TCF0  ( 32 MB)
                                     (enet: 08-00-2b-34-ee-42)
                                     (SCSI = 7)
            DEV   PID                VID        REV    SCSI DEV
            ===== ================== ========== ====== ========
            rz1   RZ29B    (C) DEC   DEC        0016   DIR
            rz5   CD-ROM CR-506      MATSHITA   8S05   CD-ROM

So I did this in order to boot from CD, but it simply hangs and does not
(not even read from the CD afaict; I can mount the CD from Linux, though.)

>>boot 3/rz5

Info about the machine:

decstation:~# cat /proc/cpuinfo
system type             : Digital DECstation 5000/1xx
processor               : 0
cpu model               : R3000A V3.0  FPU V4.0
BogoMIPS                : 32.82
byteorder               : little endian
wait instruction        : no
microsecond timers      : no
tlb_entries             : 64
extra interrupt vector  : no
hardware watchpoint     : no
VCED exceptions         : not available
VCEI exceptions         : not available
ll emulations           : 1098
sc emulations           : 1098

Martin Michlmayr

Reply to: