[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Testing cdebootstrap and debootstrap installing Woody

[Petter Reinholdtsen]
> Installing worked just fine, both commands worked just fine:
>  debootstrap sarge chroot-sarge-debootstrap http://ftp.skolelinux.no/debian
>  cdebootstrap sarge chroot-sarge-cdebootstrap http://ftp.skolelinux.no/debian

I decided it was a good idea to compare the Woody install as well, as
we use d-i in Skolelinux to install Woody.

This is the list of packages installed by cdebootstrap:

  adduser apt base-config base-files base-passwd bash bsdutils
  console-common console-data debconf debianutils diff dpkg e2fsprogs
  fileutils findutils grep gzip hostname klogd libc6 libcap1 libdb3
  libncurses5 libnewt0 libpam-modules libpam-runtime libpam0g libpopt0
  libstdc++2.10- login makedev mawk modconf modutils mount
  ncurses-base ncurses-bin netkit-inetd nvi passwd pciutils perl-base
  sed setserial shellutils slang1 sysklogd sysvinit tar tasksel
  textutils util-linux whiptail

These packages are installed by debootstrap, but not by cdebootstrap:

  apt-utils at bsdmainutils console-tools console-tools-libs cpio cron
  dhcp-client ed exim fdutils gettext-base groff-base ifupdown info
  ipchains iptables libdb2 libgdbmg1 libident libldap2 liblockfile1
  libpcap0 libpcre3 libreadline4 libsasl7 libwrap0 lilo logrotate
  mailx man-db manpages mbr nano net-tools netbase netkit-ping
  pcmcia-cs ppp pppconfig pppoe pppoeconf procps psmisc syslinux tcpd

To check the "top-level" dependencies, I installed deborphan in the
debootstrap chroot, and ran 'deborphan -a':

  main/net                 telnet        (only debootstrap)
  main/admin               pciutils
  main/base                base-config
  main/doc                 manpages      (only debootstrap)
  main/base                pcmcia-cs     (only debootstrap)
  main/base                modconf
  main/base                pppconfig     (only debootstrap)
  main/base                gettext-base  (only debootstrap)
  main/utils               syslinux      (only debootstrap)
  main/editors             nano          (only debootstrap)
  main/admin               at            (only debootstrap)
  main/net                 pppoeconf     (only debootstrap)
  main/editors             ed            (only debootstrap)
  main/base                fdutils       (only debootstrap)
  main/doc                 info          (only debootstrap)
  main/editors             nvi
  main/net                 dhcp-client   (only debootstrap)
  main/base                libgdbmg1     (only debootstrap)

Installing libgdbmg1 seem to be a mistake by debootstrap.

I suggest at least adding these to the list of packages installed by
cdeboostrap in woody:

  apt-utils console-tools cron ed exim fdutils ifupdown info logrotate
  mailx man-db manpages pcmcia-cs pppconfig pppoeconfig procpc psmisc

I suspect some of this is fixed if cdeboostrap install all required

Reply to: