[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing on Compaq Servers

  I just installed woody ( to get to sid) on an ML350 G3 last month. I feel
your pain.

On Tue, Feb 05, 2002 at 12:22:46PM -0500, Loren Jordan wrote:
> Hello,
> I'm not sure if this counts as a bug but here is the information I was able 
> to figure out.  If this should be filed as a bug let me know...

> I have several Compaq servers (DL380's and DL360's) that are of the G2 
> generation.  They have a newer raid controller (Smart Array 5i) and none of 
> the boot disks support this controller, not even the "compact" set.  The 
> compact disks have worked for me before on the G1 Compaq boxes with the 
> "smart2" array in the past.
  Actually, they do, but as a module. Rather than extract the module the
"proper" way I just went through the install past "Install kernel & modules"
on the onboard scsi then copied the cciss.o to a floppy. I was able to then
reboot on the raid card, load the module, and continue on.

> on this custom kernel floppy to make it use the ram disk from boot.bin 
> (standard or 2.4).  This almost worked except for 2 problems.  The 
> dbootstrap program doesn't know anything about the "cciss" devices.  I 
  Yeah, that's a PITA too.

> The rest of the install didn't work either as it couldn't install the 
> "rescue" floppy as my custom kernel floppy didn't look like a "rescue" 
> floppy.  I didn't want to feed it the real rescue disk as it would be an 
> un-bootable kernel. (not able to mount the root file system,etc...)
  I chroot-ed into my install from the installer and built a new kernel.
Second or third time around I got the kernel right ;)

  Any sign of linux-based tools to mangle the raid setup? Somewhere burried
in the "Insight manager" maybe?

  - Nick Lopez
Gates' Law: Every 18 months, the speed of software halves.

Reply to: