[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installing on Compaq Servers


I'm not sure if this counts as a bug but here is the information I was able to figure out. If this should be filed as a bug let me know...

I have several Compaq servers (DL380's and DL360's) that are of the G2 generation. They have a newer raid controller (Smart Array 5i) and none of the boot disks support this controller, not even the "compact" set. The compact disks have worked for me before on the G1 Compaq boxes with the "smart2" array in the past.

All of this is using "woody".

I tried the 2.4 boot floppies but this didn't work either so I made my own boot floppy (make bzdisk) with a custom 2.4 kernel with the Smart Array 5X driver support built in. I used the rdev commands
rdev /dev/fd0 /dev/fd0
rdev -r /dev/fd0 49152
on this custom kernel floppy to make it use the ram disk from boot.bin (standard or 2.4). This almost worked except for 2 problems. The dbootstrap program doesn't know anything about the "cciss" devices. I determined this by sifting through the source code. The other problem was that the /dev/cciss dir and assorted block device files were not in the root.bin floppy. This is from the machine I was working on to try to get things working.

testbox:/proc# cat partitions
major minor     #blocks  name
 104     0      17776560 cciss/c0d0
 104     1        40944 cciss/c0d0p1
 104     2     17225760 cciss/c0d0p2
 104     3       501040 cciss/c0dop3

I took the root.bin file and modified it by adding the required /dev/cciss block files using the script from http://www.linuxhq.com/kernel/v2.4/doc/mkdev.cciss.html (modifed to put them in the /temp/root.bin/dev dir where I had the root.bin-ungiped file mounted and put it back on a floppy. I was too lazy to just use the mknod command... This allowed me to start a shell while in the dbootstrap program, mke2fs and mount the drives however I had to do everything manually.

The rest of the install didn't work either as it couldn't install the "rescue" floppy as my custom kernel floppy didn't look like a "rescue" floppy. I didn't want to feed it the real rescue disk as it would be an un-bootable kernel. (not able to mount the root file system,etc...)

I believe that the things required for this to work (out of the box) would be that the dbootstrap program be modified to look for more than just the hda,sda,rd/c0d0 and ida/c0d0 disks.
#### snippet from bootconfig.c from the dbootstrap source dir #####
#define DEV_HDA      "/dev/hda"
#define DEV_SDA      "/dev/sda"
#define DEV_RD_C0D0  "/dev/rd/c0d0"
#define DEV_IDA_C0D0 "/dev/ida/c0d0"
The root floppy AND the base system (MAKEDEV ?) should have the /dev/cciss dir and associated block device files added.

After figuring this out, I added the cciss/* files to a running system and just used a tarball of this system, I un-tared it onto the mounted "/target" file systems of the new machines and everything is running just fine on these machines (after fixing /etc/fstab) however it would have been nice for the install system to have worked.

I was not able to get the boot-floppies source package to build (yet) so I am not yet able to work up a patch for the dbootstrap program.

Thanks for your time and maybe a fix to dbootstrap?
Loren Jordan

Loren Jordan

Network Security Admin
National White Collar Crime Center
Internet Fraud Complaint Center
Phone (304)363-4312 Ext 2011


Reply to: