[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: AdvanSys SCSI timeout on 1st kernel boot

Adam Di Carlo wrote:
> Marc Mongenet <Marc.Mongenet@freesurf.ch> writes:
> > Hello, I am trying to install Debian 2.2r2 from scratch (bootable CDROM
> > or floppies) but the 2.2.18pre21 kernel is (most of the time ~95%) not
> > able to recognize my SCSI drives. Here is the interesting part of the
> > kernel log (booting with Rescue compact floppy) :
> >       scsi0: Advansys SCSI 3.2M: PCI Ultra 240 CDB: IO D400/F, IRQ 10
> >       scsi : 1 host.
> >       scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 0, lun 0 0x00 00 00 00 00 00
> It's saying it's getting a SCSI timeout trying to talk to the device
> at SCSI ID #0.
> This is a pure kernel issue. Assuming it's not a hardware/scsi cable

Thanks a lot for your help,

It 's definitely not a hardware problem. It works perfectly (since 1997) with
2.0.x and also with a "simplified" 2.2.18 someone sent me.

> problem, I would recommend looking into what
> boot arguments are accepted by the program.

Well, I found nothing about AdvanSys in the Debian boot documentation.
Where should I look for ?
> If there's a problem with that kernel, please file a bug against
> the package kernel-image-2.2.18pre21-compact .

Will be done very soon.
Note that I tried with compact & non-compact, both failed.
I also tried with idepci, but had another problem :
Detected scsi removable disk sdc at scsi0, channel 0, id 5, lun 0
      sr0: scsi3-mmc drive: 20x/20x xa/form2 cdda tray
      Uniform CD-ROM driver Revision: 3.11
      SCSI device sda: hdwr sector= 512 bytes. Sectors= 8890760 [4341 MB] [4.3 GB]
      Partition check:
       sda:<3>ll_rw_block: Trying to read nonexistent block-device 08:00 (0)
       unable to read partition table

Maybe I didn't loaded enough modules, but again it's quite difficult to find
the documentation.
> --
> .....Adam Di Carlo....adam@onShore.com.....<URL:http://www.onShore.com/>

Marc Mongenet

Reply to: