[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: /boot nonexistant on sun4cdm install disk set

On Sun, Aug 13, 2000 at 06:08:02PM -0400, Adam Di Carlo wrote:
> William Cordis <whcordis@host-0080C84B1ED9.public.southern.edu> writes:
> > I have a SPARCstation 5 that I'm trying to install debian on. I downloaded
> > the 2.2.16-2000-07-14 disks from /debian/dists/potato/main/disks-sparc/sun4cdm
> > and the root.bin that I used came from 
> > debian/dists/potato/main/disks-sparc/images-1.44
> > 
> > All went fine until I tried to download the driver.tgz from http.us.debian.org
> > Since I was using DHCP to configure the machine I checked /etc/resolve.conf.
> > It was empty so I put our DNS server in there and was able to ping 
> > http.us.debian.org.  Unfortunately the perl method didn't notice the change
> > and still reported the name as unable to resolve.  Putting in the ip worked
> > and nothing else went wrong until I tried to install SILO.  It failed so I
> > ran it manually from the console.  It reported that it couldn't load the 
> > second stage boot-loader /boot/second.b.  A quick survey showed no /boot at all.
> > Did I download a bad image for my root.bin??
> Try the newer 3 August versions, I think.
> If that fails, please submit a bug against boot-floppies.

No, there should be no /boot in the root.bin. The /boot that silo uses is
/target/boot. Silo us run as "silo -r /target" so that it will chroot to
the new installed filesystem. Try running that and see if there is an
error. I'm wondering what happened to make you think it failed. Was there
an error message? If so, what was it?


/  Ben Collins  --  ...on that fantastic voyage...  --  Debian GNU/Linux   \
`  bcollins@debian.org  --  bcollins@openldap.org  --  bcollins@linux.com  '

Reply to: