[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Boot-floppies: Why depends on "cslatex", "cspsfonts"

On Mon, Jul 17, 2000 at 11:45:23AM -0400, Adam Di Carlo wrote:
> Sven LUTHER <luther@dpt-info.u-strasbg.fr> writes:
> > Don't know just an idea like that, or maybe do you not consider compiling on
> > non i386 plateforms as important ? :))))
> Of course I consider that important.  What does that have to do with
> it?  Those other pkgs are not available on non-i386?   
> (If so, that is technically a bug against cslatex etc, not
> boot-floppies, but definately something one should know about).

Ok lets me explain this confusion, but like said, if i am wrong, just ignore
me and don't take it bad ...

there are some extra package needed to build plateform specific docs, that are
not in the dependencies, but are checked in the make depend or whatever target
in the Makefile.

The idea behind those is that those package are only needed for some obscure
arch and not i386.

So here we have the same problem, we have package that are only needed for
some languages, that people wanting to build their own boot floppies (for
working on it and trying it) don't really need, and yet an apt-get install
boot-floppies will pull them in, and they are pretty big if i understood
things right (whereas the platefrom specific dependencies are often small).

So should they not be removed from the dependencies, and people wanting to
build them been told by make depend to install them ?

but again, if i am wrong, please, no flamewar (and i am aware that this topic
may be a bit provocative in his posting, but hell, don't take it too
seriously, it's just a thought.)



Reply to: