[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

2.2.5 compact - Ping segfault, mount error.

 I chose to try and install the kernel and drivers using a netfetch,
 since the driver for the net card in vmware is compiled into this
 version.  Everything worked great; `dbootstrap' is sitting at the
 screen where you enter the URL to fetch from.  (And I know enough to
 put the lully URL into the box...)

 I switched to vt2 to see if `ifconfig' would confirm the success of
 the network configuration stage.  It did, so I typed `ping
 lully.debian.org', and got an immediate segmentation fault.  I then
 set `ulimit -c unlimited' and tried it again, this time I got a core
 file.  I went to mount a floppy to copy the core and `ping' to so I
 can run `gdb' once to try and figure out where it crashed...

 ... and mount printed:

   ioctl: LOOP_CLR_FD: Invalid argument

 ... but succeeded in mounting the floppy despite the error.

 Here's what gdb is showing me about the `ping' crash:

# gdb ./ping core
GNU gdb 19990928
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...(no debugging symbols found)...

warning: exec file is newer than core file.
Core was generated by `ping lully.debian.org'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/libc.so.6...(no debugging symbols found)...done.
Reading symbols from /lib/ld-linux.so.2...(no debugging symbols found)...done.
#0  0x8055b43 in warn ()
(gdb) where
#0  0x8055b43 in warn ()
#1  0x1 in ?? ()
Cannot access memory at address 0x2.

 `ping.c' does NOT call `warn' at all.  The only use of warn is in
 `libsfdisk' and `gzip'.  What's going on here?  A buffer overrun and
 it jumped off into random space and happened to land here?  How did
 we end up in `warn'???

 You tell me and we'll both know.  It will have to be debugged.

Reply to: