[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: linux-image issue

I just removed the tmp/ and the images/ from a previous run of simple-cdd and made sure that my kernel was noted in the .downloads file. I did not pass --local-packages <pkgsdir> on the commandline.. All I ran was

# build-simple-cdd --profiles-udeb-dists sid --dist etch

This actually produced an iso. I don't think it should have since there is no way it could have found my linux-image deb (since its in that local dir). And upon inspection of the mirror it created, it did not. So I am not even going to run this iso as it does not even contain the kernel option.

I'll try something else and report back...

-----Original Message-----
From: Schneider Raymond, SH-NET (EXT)
Sent: Wednesday, November 05, 2008 8:11 AM
To: debian-custom@lists.debian.org
Subject: RE: linux-image issue

If Im not mistaken the priority in the control file is optional. As to whether or not I have re-built with a fresh mirror, I have done both as I have experimented with this situation. I tend to favor starting over by wiping the tmp/ that gets created by issuing a rm -rf tmp. I have found that doing so tends to lessen errors and unexpected outcomes. (I can't give a specific example of this, other than if I changed a package, but left it named the same, it would not build the new version of the package into the system. I believe I understand why that happens, but nevertheless...)

Its an interesting suggestion to run without --local-packages. How would simple-cdd know where to get my linux-image deb (since its in the dir defined by local-packages argument) if I do not provide it? For the sake of completeness, I will go ahead and run again without providing local-packages and leaving my linux-image deb in the .downloads file and see what happens. I will also be doing this having just removed the tmp/ created by simple-cdd.

I'll report back in a little while with another response.

Thanks again for responding to my questions. I appreciate your efforts to help and frankly what simple-cdd represents as a piece of software.


-----Original Message-----
From: Vagrant Cascadian [mailto:vagrant@freegeek.org]
Sent: Tuesday, November 04, 2008 3:45 PM
To: debian-custom@lists.debian.org
Subject: Re: linux-image issue

On Mon, Nov 03, 2008 at 09:44:48PM +0100, Raymond.Schneider@swisscom.com wrote:
> I have run simple-cdd as follows:
> # build-simple-cdd --profiles-udeb-dist sid --dist etch --local-packages /full/path/to/pkgsdir

> This as I understand it should have build an iso based on the default
> profile... That said, I added the linux-image pkg I am trying to get
> installed... just to see if I could get it on the iso only.. and not get
> installed, I only added it to the default.downloads file. I added no d-i
> command to the preseed or anything other packages to the default.packages
> file..

thanks for this information.

do you get the same error when running without including --local-packages ?

have you re-built with a fresh mirror? i.e. wiped out
$your_simple_cdd_workdir/tmp and started over?

> As usual I was able to build yet another iso that fails on 'unpacking
> required packages.' The thing that's bugging me is I had thought that adding
> it to the profile.downloads would get the pkg from my --local-packages dir
> and put it on the iso, not try to install it..

what's the priority set on the custom linux-image package?

lesspipe linux-image*.deb | egrep -i priority

live well,

To UNSUBSCRIBE, email to debian-custom-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: