[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: samba unmet dependencies

* Christian Perrier <bubulle@debian.org> [2009-10-20 06:34:53 CEST]:
> Quoting Wolfgang Granzer (w@auto.tuwien.ac.at):
> > May be I have missed the point but I am still not able to upgrade to
> > the backports package of libpam-smbpass:
> > 
> > The following packages have unmet dependencies:
> >   libpam-smbpass: Depends: libpam-runtime (>= 1.0.1-6) but
> > 1.0.1-5+lenny1 is installed
> I'm not in position of checking this right now but it's very likely
> that I need to undo yet another change we made to unstable packages:
>   * debian/libpam-smbpass.pam-config, debian/libpam-smbpass.postinst,
>     debian/libpam-smbpass.files, debian/rules: provide a config block
>     for the new PAM framework, allowing this PAM module to
>     auto-configure itself
>   * debian/control: make libpam-smbpass depend on
>     libpam-runtime (>= 1.0.1-2ubuntu1) for the above

 But 1.0.1-5+1lenny1 _is_ >= 1.0.1-2ubuntu1. I think you might just have
either looked at the wrong changelog entry or reduced the versioned
depends too little.

 Hope that helps. :)

Reply to: