[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Packaging Aravis for debian-astro blend



Hi Ole,
thanks for your review, I'm working on it...

> Then, I still get a few lintian problems:
> 
> E: aravis source:
> gobject-instrospection-package-missing-depends-on-gir-depends
> gir1.2-aravis-0.6
> W: aravis source: typelib-missing-gir-depends gir1.2-aravis-0.6
> W: gir1.2-aravis-0.6: gir-section-not-libdevel
> usr/share/gir-1.0/Aravis-0.6.gir introspection
> W: gir1.2-aravis-0.6: gir-missing-typelib-dependency
> usr/share/gir-1.0/Aravis-0.6.gir gir1.2-aravis-0.6
> W: aravis-tools: appstream-metadata-in-legacy-location
> usr/share/appdata/arv-viewer.appdata.xml
> E: aravis-tools: appstream-metadata-legacy-format
> usr/share/appdata/arv-viewer.appdata.xml

How can I reproduce the output of lintian on the unstable distribution?
Do I really need to install it (but I need debian 9 too and I'm a little worried of the time consuming maintenance of more than a system...), or is there a way to run it during the pdebuild process?

Thanks for your help!
Best,
Chiara

-- 
Chiara Marmo
Ingénieur de Recherche GEOPS - Paris Sud-11
Bât 509
Tel: +33 (0)1 69 15 49 03 


Reply to: