[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: odd result for sudo dpkg -V

Gene Heskett dijo [Fri, Nov 05, 2021 at 12:32:44PM -0400]:
> On Friday 05 November 2021 10:22:11 Markus Weyermann wrote:
> > I ran it on RPi4B RaspberryPi  OS aarch64 Buster and got

Please do note that we (Debian) do not control how dpkg works on
RaspberryPi OS -- It is a Debian derivative, but it deviates quite a
bit from us.
> Thats exactly what I got, around 200 of them.  And its quasi-random, I 
> ran it again on my raspian pi4b with a |wc -l and only got 87 next time.

Ugh, that is even worse! :-(

I ran it on a clean Debian, on my Raspberry p400 (using one of the
Bullseye images from https://raspi.debian.net/), and got:

    root@rpi-p400:~# dpkg -V
    ??5?????? c /etc/fuse.conf
    ??5?????? c /etc/default/raspi-firmware

Both are conffiles, and while I don't remember (but don't rule out)
having modified the first one, I'm sure I have touched the second one.

I rebooted the system and ran it again, and got the exact same

> I think the armhf and arm64 versions have a bug. The machine is otherwise 
> fine and could be carveing steel 2 or 3 minutes after I got to it.  
> Takes that long to properly chuck up a workpiece.
> That is not a commonly used option, but I used it because dpkg reported 
> an incomplete quite a few packages update this morning and I was looking 
> for the cause. But a sudo -E synaptic said its all fine, no errors, no 
> fix-brokens etc.

I suggest you bring this issue up on the Raspberry Pi Foundation's
tracker, as it does not seem to be related to Debian.

Reply to: