[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Fwd: Help needed debugging on ARM

Forwarded to debian-arm from debian-mentors:

-------- Original Message --------
Subject: Help needed debugging on ARM
Date: Wed, 29 Aug 2012 08:57:17 +0200
From: Michael Wild <themiwi@gmail.com>
To: debian-mentors@lists.debian.org <debian-mentors@lists.debian.org>

Dear all

I want to resolve a very strange build failure that is happening on all
ARM architectures. The package builds some of its documentation images
with asymptote, which fails [1].

Since I don't have any ARM hardware, I tried to use QEMU. I tried both a
full VM and a cowbuilder-dist environment. However, the asy executable
just locks up and doesn't finish for hours. From looking at the verbose
output, it looks like it's reading its basic module, plain.asy. However,
I can't confirm this, since strace doesn't work in QEMU.

So, I'm a bit stuck here and would like to ask whether anybody has an
idea how I could investigate the build failure (I don't really care to
resolve the QEMU issue, though ;-))

Thanks for any of your valuable help



Reply to: