[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gnat in debian armhf

On 18 January 2012 03:04, peter green <plugwash@p10link.net> wrote:
> It seems ubuntu armhf already has gnat-4.6 but it's blocked from
> autobuilding in debian due to a depency loop (gnat-4.6 build-depends on gnat
> which depends on gnat-4.6). Can someone get this bootstrapped so libreoffice
> can build*?

According to


there is no gnat-4.6 debs for ubuntu armhf, where did you get this info from?
For the record, I've been trying for weeks to get armhf debs for gnat,
I partially succeeded, I have armhf debs running, but as it was
configured with zcx, which is not supported on arm, it fails to
compile ada source, I have to rebuild it using sjlj only. Tried to do
it on more recent gnat source, but it failed to build. So, getting
there, hopefully soon.

> * libreoffice build-depends on mingw-w64 which is uninstallable because
> gcc-mingw64 is not built. gcc-mingw64 is not built because of a
> build-depends on mingw-w64

Seems like a manual upload is in order for this.


Reply to: