[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't boot kernel 3.0.8 on Efika smarttop

Le Wednesday 4 January 2012 18:27:17, Arnaud Patard a écrit :
> > I may be a bit optimistic: I've tried to boot a Efika Smarttop box on a
> > 3.0.8 
> > kernel. The boot stops right at the beginning with the following message:
> if you want to boot a vanilla kernel, why don't you try 3.1 armhf kernel ?

In fact I want to test some application based on libsdl-perl from experimental 
(the one I uploaded a few weeks ago). For this, I'd rather use Debian/sid to 
avoid backporting lots of stuff. Hence I don't want to experiment on a too old 
kernel lest I run into trouble because of mismatch between recent user space 
in sid and old kernel.

So a vanilla kernel is good enough, I don't need performance (well I hope not, 
although SDL was slugggish through qemu-arm-static :-/ )

> the boot is in quiet mode and there's no command line in your mail but I
> assume that you're trying to boot on pata and that the kernel just
> panic'ed. If you really want 3.0, you can only use mmc. The pata support
> was added mainline later and it was backported in our 3.1 kernel
> (3.1.1-1).

I was booting from a SD card following the instructions there:

The kernel command is:
setenv bootargs console=ttymxc0,115200 root=/dev/mmcblk0p2 rootwait rw quiet 

oh right, I did not see the quiet command when I cut'n'pasted that from 
efika's boot script. I should probably get rid of the splash stuff also.
Thanks for the tip.

All the best

http://config-model.wiki.sourceforge.net/ -o- http://search.cpan.org/~ddumont/
http://www.ohloh.net/accounts/ddumont     -o- http://ddumont.wordpress.com/

Attachment: signature.asc
Description: This is a digitally signed message part.

Reply to: