[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Qnap TS-210] don't boot anymore

Hi all,

back with some news, now that I've a serial-cable and some time.

(Sorry, I'm too long...)

[Quick ref. to first message:
 http://lists.debian.org/debian-arm/2010/09/msg00079.html ]

Last state: a not-booting-anymore installation (2x2TB, RAID-1,
8GB ext4 /) with a linux-image-2.6.35-trunk installed by:
- tftpbooting on debian-installer
- mounting target, /proc and /dev
- chrooting
- dpkg ---force-depends -i *.deb (had to change from UUID to 
  /dev/md1 in fstab to please initramfs-tools)
- flash-kernel was automatically called.

The boot fails because of:
FATAL: Error inserting raid1 (/lib/modules/2.6.35-trunk-kirkwood/kernel/drivers/md/raid1.ko): 
Invalid module format
Failure: failed to load module raid1.

Hence no root, no /sbin/init, hence initramfs' busybox waiting.
No FS from the hdd is mounted, so it's not the same problem I had 
with my first installation (there were writings on the disk).

I decided to try a new  installation (again). I reinstalled Sid.
Same configuration: 3 RAID-1 partitions, 512MB swap, 8GB / ext4,
2TB /home ext4. Reformatting / only.

The boot fails with:
Begin: Running /scripts/local-premount ... done.
mount: mounting /dev/sda2 on /root failed: No such device

/dev/sda2 is a part of /dev/md1 (which is /).
It should be /dev/md1.

As I surmise the error occurred during the initrd image
construction, I tried again:

To be really sure, I got the latest testing installer and changed
the partitions (swap of 512MiB instead of 512MB, / of 8000MB, and
/home inside an LVM, for easy snapshots (maybe).

This time, I didn't close the installer without verifying the
installation logs (yes, it seems I can learn):

Oct  8 22:17:45 in-target: update-initramfs: Generating /boot/initrd.img-2.6.32-5-kirkwood
Oct  8 22:17:45 in-target: df: 
Oct  8 22:17:45 in-target: Avertissement : ne peut pas lire la table des systèmes de fichiers 
Oct  8 22:17:45 in-target: : Aucun fichier ou dossier de ce type
Oct  8 22:17:45 in-target: 
Oct  8 22:17:48 in-target: UUID 2c064f75-5ef4-4390-9993-977a697aca49 doesn't exist in 
Oct  8 22:17:48 in-target: Warning: /etc/fstab parse error; guessing that the root device is 

And that's true: only md0's UUID appears in /dev/disk/by-uuid.
That's the same problem I had in 1 (above) when I manually installed
2.6.35-trunk, two weeks ago. I then thought that was because I
didn't do everything that was necessary in the chroot.

I changed the fstab to use /dev/md1.
update-initramfs -u worked.
Reboot and ... it works!

I'm not sure that this is same problem I first had. It surely is the
one I had when I tried to reinstall but / cannot be mounted with this
problem whereas I managed to have files created on the disk with the
first installation.
Nevertheless, it now works and I will be very careful with kernel
updates from now on.

Now, I would be interested in the proper way to correcting this
(within the installer's busybox would be again better) and, above
all, knowing _why_ it happens.

I found those bugs reports that seem to be related:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=593375 (but my root
 is NOT in LVM)

 Sylvain Sauvage

Reply to: