[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: guruplug notes

On 05/23/2010 07:36 PM, Daniel Kahn Gillmor wrote:
> More notes on the way when i sort anything else out.

Thanks primarily to a really stupid keyboard slipup, i now have a
guruplug running entirely debian code (with the exception of uboot,
which is running 2010.03-01266-g42f7128, compiled by Clint).

The slipup was when i tried to replace uboot, i accidentally erased
*all* the NAND instead of just replacing the first 1MB (corresponding to

The uboot upgrade involved fetching the file from a local TFTP server:

setenv serverip
setenv ipaddr
tftp 0x6400000 guru/u-boot.kwb
nand erase 0 0x100000
nand write.e 0x6400000 0x0 0x100000

But instead of "nand erase 0 0x100000", i slipped and hit enter when the
command was simply "nand erase".  DO NOT DO THIS IT WILL NUKE YOUR
ENTIRE FLASH!  heh.  it's fast, though ;)

so anyway, i was starting from scratch.  using the new uboot, I fetched
the uImage and uInitrd i'd made earlier (with MODULES=all, about 6MiB in
size).   Fortunately, the NIC worked fine from the initramfs shell i got
dropped into.

I used the shell in initramfs (and a local server) to fetch and unpack
enough packages into the initramfs to pull off a stock debootstrap.

I'm currently still booting the device from the kernel/initrd over tftp.
 I hope to followup with tbm's suggestion of the new flash-kernel to get
it back to an all-local boot sometime in the next few days.

At that point, i'll start looking at the wireless business again.

I'm happy to answer questions if folks have them.


PS Is there some reason uboot itself is not in debian?  or is it, and i
just don't know how to look for it?

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: