[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: E220 Modem

Apparently people have managed to get this modem working on the NSLU2 under different firmware ie openWRTso it seems like a Debian issue, I did find this....

It is a conflict between usb-storage and the option module. You should disable the usb-storage for the mode.

However I need the usb-storage module as I'm using a usb hard disk.

More info....
HUAWEI E220 is supported natively by Linux, over usbserial.ko
(usbserial-generic) interface. Linux kernel versions prior to 2.6.20
have some problems with it.

> Date: Mon, 7 Dec 2009 11:56:02 +0100
> From: wouter@debian.org
> To: brianplatt@hotmail.com
> CC: debian-arm@lists.debian.org
> Subject: Re: E220 Modem
> On Sat, Dec 05, 2009 at 09:48:37PM +0000, Brian Platt wrote:
> > I've been trying for ages to try and get my T-Mobile E220 modem working on my
> > Linksys NSLU2 but I can't for love nor money and hoping someone on here can
> > help me, here's some info....
> Perhaps the NSLU2 is just too slow to be able to manage the data rate
> properly?
> I've been having similar issues with a USB GigE NIC that I tried
> connecting to my NSLU2. Worked just fine on my laptop, wouldn't even
> initialize on the NSLU2. I can't be sure, of course, but since the
> bitrate is much higher than the clock frequency, it's not impossible
> that the system just can't keep up with the interrupts DMA requests or
> whatever that the USB device needs to do.
> Of course I never got to prove this theory, so that's all that it is.
> (Side note: yes, I know how stupid the concept of a USB GigE NIC is, but
> the shop had no other choice.)
> --
> The biometric identification system at the gates of the CIA headquarters
> works because there's a guard with a large gun making sure no one is
> trying to fool the system.
> http://www.schneier.com/blog/archives/2009/01/biometrics.html

View your other email accounts from your Hotmail inbox. Add them now.

Reply to: