[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian-etch and ssh disconnects

This is with version of the kernel.

Is this something others have seen?

Yes, and its damn annoying! :) Its not just SSH sessions that randomly hang, but any socket for me. (2.6.18-3-ixp4xx).

I got my NSLU2 on Wednesday, and this locking up was constantly happening while trying to install using Martin's (Hi mate!) image. I was going onto a 1GB flash drive, and was manually putting 256 MB of swap in so it wouldnt run out of memory while formatting, but that failed about three times. In the end I installed onto a partition of a 400 GB HDD, with 1GB of swap. Only about 9 MB of swap is being used at the moment, but every type of service I have installed and tried to use seems ot lock up when copy data: FTP (proftpd), SMB (Samba), SCP and interactively using SSH. Its not a complete lock up as other shells (if I have two open, for example) remain responsive.

I created a separate 40 GB partition, put an LVM Volume Gruop on there and make a logical partition with an XFS file system. I then hooked up rsync to point to it, and tried to rsync using the win32 cwRsync binaries to copy as well, and that actually made LVM complain about filesystem corruption (twice). Accessing the same data using other methods (eg SMB) did not cause this.

Anyway, this is little device is very cool (if I/we can fix the hanging issue). I'm even being teased at work for talking about my slug. They think I am talking about my....

Martin, I was looking to use the rest of my disk as an iSCSI target, but while the scsi_transport_iscsi is in your kernel, the iscsi_tcp doesn't seem to be. Has anyone else got iSCSI targets working from their slugs???


 James Bromberger | www.james.rcpt.to | james_AT_rcpt.to
 UK Cell: +44 7952042920 | Perth/Au phone in London/UK: +61 8 6424 8325

fn:James Bromberger
adr:;;;London;Greater London;;United Kingdom
note:GPG: 3F2C F8FD B2D5 AA35 C81A  F914 A5F2 7028 0917 A9E4

Reply to: