[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't tftpboot my Netwinder...

B. Douglas Hilton wrote:

Yeah, something is wrong with your network
settings or something. It can't find/get the
file. Set the eth0 to "flash" and make sure you
can tftp the file from the server locally too.

Great!  That was the key, setenv netconfig_eth0 flash did it.

What follows is the rest of the story of my install...

So it gets the image and boots, but can't find root. If I leave the settings as-is, it tries to use my existing root, with bad libc, and init doesn't even start. If I try to set rootdev to /dev/ram0, it "Can't mount root device on 01:00". It took a while to realize this is because the "noinitrd" option is part of cmdappend; removing that made it work. (Could this be added to the docs?)

So I tried reinstalling libc6 a couple of ways: using ar and tar gave me a chrootable system, but then chroot and dpkg -i libc6...deb resulted in a differently-broken system: every command was "no such file or directory". Couldn't figure out how to recover: doing the same ar and tar trick to unpack the libc6 deb in /target didn't fix the problem. Oh well, have to reinstall.

So I began to reinstall into the other partition, the one that used to have RedHat. It worked well except for one thing: "Install the operating system kernel and modules" failed because netwinder/images-1.44/rescue.bin does not exist! This must be fixed before the woody release: either we need to generate rescue.bin, or have the installer install the kernel from a different file.

Aside from that, the installation went great. I really like the new base system installer, that it goes and gets the packages is really cool I think. With the manual installation of the kernel and modules, the install seems to have succeeded, I rebooted successfully, set the root password, etc.


   * Install operating system kernel and modules is broken because it
     tries to get missing netwinder/images-1.44/rescue.bin.
   * Documentation should mention the need to disable noinitrd in

Thanks, the boot floppies are otherwise great!


-Adam P.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

Welcome to the best software in the world today cafe! <http://lyre.mit.edu/%7Epowell/The_Best_Stuff_In_The_World_Today_Cafe.ogg>

Reply to: