[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems installing on ARM710

On Wed, Feb 14, 2001 at 04:27:20PM +0100, Richard Atterer wrote:
> I booted with Peter's 2.2.16 kernel using the new root image, and
> the crash immediately after the splash screen no longer occurs. I
> haven't yet tried base2_2.tgz,

Here's an update on my progress:

With Wookey's root image, the whole installation process up to the
reboot worked smoothly, with one exception: dinstall somehow got stuck
after I had pressed Return to set the hostname. After a while, I just
killed the dinstall process. When it was restarted, it dropped into
the "Enter hostname" dialog again immediately, and this time it
worked. I've been unable to reproduce that failure.

I noticed one oddity WRT booting the kernel: Occasionally, after I
pressed Return at the "Extra arguments" question, there would be disk
access, but then the machine seemed to crash (Ctrl+Break didn't work
to reset it). This happened roughly 50% of the time. Just by instinct,
I altered !Linux.!Run to always allocate 4M of memory, and this seemed
to fix it (I tried about 5 times without problems). However, it only
fixed it for Peter's 2.2.16 kernel, I have had one freeze for Phil's
2.4.1-debug kernel. I'm up to 8M now and this appears to work, but
maybe I'm just lucky... :)

Rebooting from the installer didn't work (the RiscPC also seemed to
crash), but no problem.

I booted Linux again for the second installation stage. Unfortunately,
things started breaking again here - presumably Wookey recompiled the
boot-floppies stuff, but did not recompile everything in base2_2?

The first unusual thing is an error message from grep, "grep: Regular
expression too big". This happens for any call to grep, e.g. "grep x".

Second, gzip still segfaults. My brain belatedly informed me of the
existence of the catchsegv utility, so I've been able to attach a more
detailed stack backtrace...

The boot process then enters an infinite loop, apparently due to gzip

  Loading /usr/share/keymaps/acorn/ps2.uk.kmap.gz
  chld_handler(): Decompressor child was terminated by signal 11.

Thanks for all your help so far! More hints and gzip/grep binaries are
welcome! :)
All the best,

  Richard (with sore finger from pressing the Reset button)

Here's the gzip trace:
*** Segmentation fault
Register dump:

 R0: 00000001   R1: 0000002f   R2: bffffe04   R3: 00000001
 R4: 0000002f   R5: 00000000   R6: 00000001   R7: 4001d8b0
 R8: 02000a18   R9: 401091b4   SL: 40109cbc   FP: bffffd58
 IP: bffffd5c   SP: bffffd44   LR: 4007f658   PC: 4007e4ec

 CPSR: 20000010

 Trap: 0000000e   Error: 00000000   OldMask: 00000000

  __   _
  |_) /|  Richard Atterer           | CS student at the Technische | GPG key:
  | \/¯|  http://atterer.net        | Universität München, Germany | 888354F7
  ¯ ´` ¯

Reply to: