[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems installing on ARM710



Hi all,

well, it seems there *are* problems with the boot floppies on ARM710s
after all. :-(

I tried to start the installation process using the latest 2.2.16 boot
floppies from ftp.arm.linux.org.uk, built on 2000-09-06.

When I start the installer (from plain RISC OS 3.7, without anything
booted or any modules loaded, and no extra args to the kernel), I get
the splash screen, and after I press Return, the "is determining the
current state..." message appears for a very short time, there is some
disc access, and dbootstrap segfaults (whereupon it is immediately
restarted by init).

I tried switching off the ARM710 cache with "cache off" under RISC OS
prior to starting the installation, but it makes no difference.

My machine is a RiscPC 700 (i.e. 2nd rev motherboard), upgraded to
RO3.7 (the SA that came with it broke, hence the ARM710), 40MB + 1MB
VRAM, stock Acorn IDE interface with a Hitachi ATAPI CD ROM and a 3GB
Seagate drive.

After the failure, I also attempted to continue by installing
everything manually. Formatting the partitions and unzipping
base2_2.tgz worked OK, but e.g. "apt-get update" or the "gzip"
contained in base2_2 also segfaults. Maybe someone would be willing to
mail me a version of, say, gzip compiled with debugging support, and
other tools to pinpoint the segfault? (What other programs do you
actually need?)

Many thanks for any help you can offer,
All the best,

  Richard

-- 
  __   _
  |_) /|  Richard Atterer           | CS student at the Technische | GPG key:
  | \/¯|  http://atterer.net        | Universität München, Germany | 888354F7
  ¯ ´` ¯

Attachment: pgp3XupCaJbEa.pgp
Description: PGP signature


Reply to: