[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2nd RiscOS install kit, a little better maybe

>    I will take a shotgun approach this time and make 4 install images
>    for the combinations of ( Image, vmlinux) X ( embedded, external)root.
>    The file names should explain which is which.

see below - bit more testing needed to be categorical.

> 3) Some devices work, some don't.  I'm sticking my ".config" file from
>    the kernel into the distribution directory so people can make 
>    recommendations.

>    etherM : no

driver passed on to Jim/phil to integrate

>    etherB : tries but fails

It seems this may just be my card (MAC address not blown into ROM as it
should be. New ROM coming - we'll see...

>    Load Installer Kernel
>      (Netwinders use NeTTrom to get off of existing disk or over TFTP)
>      (Acorn can use !Linux or !Linloader, see other references)

OK. deb-riscos-image-fd0root boots OK with linloader. Not yet tested with

Phil is correct to say that vmlinux images are not understood (linloader
just crashes, not yet tested with !Linux).

>    Load Installer Root Filesystem
>      (For Netwinders I build this into the root image to make life easy)
>      (Acorn, I'd like to build it in to the root, but that may not work,
>       floppy is an option.  This is the 'root.bin' file.  It should be
>       "dd"d onto a floppy)

I can't get it to see the root image images-1.44/root.bin. 

1) giving the 'root=/dev/fd0' option causes it to try and load the floppy
image but that immediately gives an oops (is there an easy way to catch
this to save me typing in a page of guff? - is it actually any use to
anyone - I suspect there is a fundamental problem with the floppy, see

2) I tried passing root.bin as an initial ramdisk, which gets past
Compressed image found at block 0....but then gives 
VFS: Mount ed root (ext2 filesystem). 
VFS: Cannot open root device 00:00 
kernel panic..

If I try the rescue.bin image instead it's the same but with 'Error:
unable to open an initial console -- intird bypassed' between the two VFS

Not sure why this isn't working. I can loopback mount the rescue.bin
image OK, and the root.bin image after I've ungzipped it (on a kernel 2.2
i386 machine), so there's nothing fundamentally wrong with them.

>    Partition Disc
>      (acorn will only have a chance to work on PC partitioned disks.
>       I think we need some sort of Acorn partition tool or it has to be
>       done back in RiscOS before starting the install.)

This is normally done on the RISCOS side first with !Partman - I don't
think there is a version of fdisk/cfdisk that understands the various
RISCOS partitioning schemes (correct me if I'm wrong?)

>    Install Operating System Kernel and Modules
>      (Acorn can use floppies or maybe network.)
>       This uses the "rescue.bin" image for operating system.  This is a
>       netwinder only image.  I don't know how to install the OS for RiscOS,
>       so presumably you will do that by hand and tell me.  Then I'll make
>       a RiscOS "rescue.bin".
>       This step also uses...
>         images-1.44/driver-1.bin  (for floppy) or
>         drivers.tgz (for network)

Appeared to work with the March 30th image (and Feb 22nd .tgz and .bin
files) over NFS. drivers and base filesystem installed (or at least
appeared to -I haven't managed to boot it yet to proove it) (If I set
'root=/dev/hdb1' I get  EXt2-fs: unable to read superblock ADFS-fs error
(device 03:41):unable to read superblock. kernel panic.

I'm not sure why ADFS is trying to get a look-in here. This drive is
PCBIOS partitioned with a linux and linus swap partition, or at least it
was when I started the install, but looking at it now with my partition
tool the table seems to have been deleted....

I also tried using this kernel to boot with my old redhat ARMLinux
partition as root - that mounted but generated a huge stream of kmod
errors - presumably some horrible mismatch of aout/elf bits or something.

Floppies don't work. If I try to install from fd0 or fd1 nothing happens
to the drive (no motor spin-up, no led). /var/log/messages vt shows:
'Mounting /dev/fd0 on /floppy failed: no such device'.

The currently mounted root at this point indeed has no /dev/fd0, and it
presumably should. perhaps support for the Acorn floppy is missing?

I'll take a look at a rescue.bin and the docs and see if I can help with
what should be on it.

>    Configure Drivers

This didn't work properly, but then I was using a mismatched set of
kernel and drivers.tgz, so I wouldn't expect it to. (I've only got a 64K
connection so I hadn't managed to download all the stuff yet, despite
being on-line all afternoon). This looks promising.

>    Install the Base System
>      (Netwinder use network)
>      (RiscOS can use network or floppies)
>       This step uses...
>         images-1.44/base-*.bin  (for floppies)
>         base2_2.tgz (for network)
>    Configure the Base System

Seemed to work fine (well, no errors anyway)

>    Make Bootable from Harddrive
>      (Dummy step on netwinder)
>      (RiscOS people will have to tell me what to do)

OK. this requires loadmap. 
I've mailed jim the SRPM and some details.

>    Make a bootable floppy

This doesn't work (see other floppy problem comments). var/log/messages
umount: no such file or directory
umount: invalid argument

>    Reboot
>      (Presumably RiscOS people have figured out there is a stripped down
>       shell over on vt2 and have done something to make this bootable,
>       or maybe they have a kernel the !LinLoader or something.)

rebooting works OK. I haven't yet managed to make a drive bootable. (I
normally boot with the RISCOS loader as it avoids a range of possible

One other small point. The cursor keys don't work (escape codes printed
on terminal) in the vt2 shell. Is this a keyboard mapping issue, or a
terminal config issue?

Aleph One Ltd, Bottisham, CAMBRIDGE, CB5 9BA, UK  Tel (00 44) 1223 811679
work: http://www.aleph1.co.uk/     play: http://www.chaos.org.uk/~wookey/

Reply to: