[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: My new Etch 2.6.18-4 install segfaults and freezes!

On Tue, Apr 03, 2007 at 02:15:50PM -0700, marie s wrote:
> Hi, I just tried to install etch from dvd on an AMD64
> system and after the install, things have begun to go
> very badly .... system has been working fine for a
> day, but today dselect exited with an error about
> corrupt /var/cache files, and when I rebooted with the
> DVD, the debian installer said that the dvd (all 3 of
> them!) were corrupt.
> But since the "corruption" was reported in different
> files every time I ran the test, I decided to look
> closely at the system. Trying to check the partitions
> wtih e2fsck caused the system to lock up, I get kernel
> panics randomly when I reboot, and now most
> applications  segfault on me.
> I don't even know where to begin to try to fix this. I
> can't install new software, I can't run most
> applications, I have no idea what could be wrong. But
> I know that I get these problems pretty steadily
> today, whether booting from the hard drives or the
> rescue dvd. Could this be a hardware issue? Anything I
> can do to debug the problem?
> Your assistance is greatly appreciated.

Certainly my first suspicion is also bad ram.  You didn't say which
chipset the machine uses or anything else so hard to guess anything
based on that.

As for dselect, why use that?  aptitude is the official curses
interface now, and is far superior and makes much more sense.  dselect's
dependency handling isn't very good.

Personally I tend to stick to apt-get and dpkg on the command line, but
I will occationally use aptitude.  aptitude could even be used as a
command line tool, but I never remember that when I need it.

Len Sorensen

Reply to: