[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: AMD64 port on a Shuttle ST20G5

Lennart Sorensen wrote:

On Tue, Jan 10, 2006 at 12:28:06PM +0100, Robert Cates wrote:
I was wondering if anybody else has a Shuttle ST20G5 with an AMD 64 Athlon and has successfully installed the AMD64 port on it.? I have tried various Linux (x86_64) distros, like Debian 3.1r0, Fedora Core 4, Ubuntu 5.10, Kubuntu 5.10 and Gentoo 2005.1 with mostly a 'kernel panic' at bootup. In fact, the Debian installer gets to a point and then has a problem accessing the CD drive. The FC4 installer starts up but when I press enter for the default install, it gives:

<ffffffff8010fc2b> {child_rip+0}
Badness in panic at kernel/panic.c:119 (Not tainted)

Ubuntu/Kubuntu 5.10 for the AMD64 gives:

[30.965542] <0>Kernel panic-not syncing: Aiee, killing interrupt handler!

At first I thought this might have something to do with the built-in ATI X200 Radion IGP, so I bought an Nvidia PCI-e card, but no change. I've upgraded the BIOS on the Shuttle to the newest available - ft20s018, and I've made various changes to the BIOS, all with no change. I've tried with APCI disabled, assigning an IRQ to the video and USB enabled and disabled, and other options enabled and disabled, but nothing helps.

If anybody has a solution I'd greatly appreciate it. I really thought this was good hardware when I bought it (specifically for the AMD64 port), so I'd hate to think I've waisted my money.

Well ATI chipsets so far seem to cause a lot of pain.  2.6.12 and higher
seems to do better.

Does an i386 distribution work on it any better?  Meaning: Does the
hardware hate current linux support in general, or only in 64bit mode.

Len Sorensen
Actually I was thinking about trying an i386 installation but haven't yet, because I bought the Shuttle specifically for the AMD64 platform and have been determined to get it running. I might try it (i386) later, but first I'll try the suggestions I'm getting from you fine folks on this list.


Reply to: