[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Software RAID, LVM, and LILO on amd64 sarge

On Fri, Nov 04, 2005 at 04:20:59PM -0600, Thomas F. O'Connell wrote:
> After discovering that the amd64 Debian Installer netinst images have  
> been broken recently, I retreated to sarge.
> At first glance, I was having pretty good luck, but I ran into a snag  
> during boot loader installation.
> During partitioning, I set up both software RAID1 and LVM. After  
> partitioning, I tried to install LILO in the MBR on /dev/md0, but it  
> didn't work. I tried advanced mode and tried /dev/mapper/vg-root as  
> an installation target, but that was invalid, as well.
> I've seen posts suggesting that this ought to work without a non-LVM / 
> boot partition, so I'm wondering whether this is an issue that's  
> peculiar to sarge on amd64?

If you setup your system like this (quite doable with sarge installer
last I tried):

/dev/sda1 /dev/md0 /boot (128M or so)
/dev/sdb1 /dev/md0 /boot (128M or so)
/dev/sda2 /dev/md1 / (Maybe 10G or whatever makes sense to you)
/dev/sdb2 /dev/md1 / (Maybe 10G or whatever makes sense to you)
/dev/sda3 /dev/md2 LVM
/dev/sdb3 /dev/md2 LVM

swap, /home, etc all as volumes inside lvm.

Then install grub to /dev/sda and /dev/sdb (The MBR of each physical
disk, being the _only_ MBR there is).

/ and /boot could be combined if you want.  Most modern systems have no
need for a seperate /boot.

And for your own sanity, pretend lilo doesn't exist anymore.

Len Sorensen

Reply to: