[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Software RAID, LVM, and LILO on amd64 sarge

On Nov 4, 2005, at 5:37 PM, Thomas F. O'Connell wrote:

On Nov 4, 2005, at 4:38 PM, Gilles wrote:

During partitioning, I set up both software RAID1 and LVM. After
partitioning, I tried to install LILO in the MBR on /dev/md0, but it
didn't work. I tried advanced mode and tried /dev/mapper/vg-root as
an installation target, but that was invalid, as well.

I think that you have to use an actual disk or disk partition as target. At least, that's how I did it with "grub" where a disk is specified with
something like "(hd0)" and a partition as "(hd0,0)".
To have the loader available, even if one of the disks in the array
fails, you just install it on every disks that composes "/dev/md0".

I thought I had read that grub didn't play well with sarge.

Unfortunately, now I'm struggling even to get RAID1 set up the way I'd like, even without LVM.

Maybe this is about the methodology I'm using rather than a problem with the installer, although I would expect the installer to be a little more intuitive. I have a two-drive machine (two 250 GB drives), and I'd like to configure them in a RAID1 such that each disk is bootable.

I thought that I could just configure each disk with a single physical RAID volume partition and then create a software RAID in which I could create as many partitions as I want, including a / boot partition if need be.

But I'm running into issues with seeing the remainder of the disk space be flagged as "unusable" as soon as I create a partition in the RAID1.

Okay. Sorry for the noise of my reply. I read this a little more closely:


But this leaves me with my original problem.

What I'm doing now is:

1. Set up a monolithic physical volume for RAID on each disk.
2. Configure RAID1 using these volumes.
3. Configure a single LVM volume group (vg) with four logical volumes in it: root, swap, var, and home. I don't specifically create a volume or mount point for /boot, but I haven't gathered that that should be necessary.

The installer partitions all this just fine but can't seem to figure out what to do to install LILO (which is the only option available for boot loader once I've partitioned with LVM, reinforcing my thinking that grub doesn't play nicely with LVM).

Once I reach this step, with this configuration is there any way to specify an actual disk or disk partition as a target for LILO? By default, it tries to select the Master Boot Record of /dev/md0, which doesn't work. The default attempt for Advanced mode is /dev/md/0, which also doesn't work. Nor does /dev/vg/root, nor /dev/mapper/vg-root.

Again, I'm not sure whether this is a LILO/amd64 issue. If this is better posted on another list, please let me know.

Thomas F. O'Connell
Database Architecture and Programming
Sitening, LLC

110 30th Avenue North, Suite 6
Nashville, TN 37203-6320
615-469-5151 (fax)

Reply to: