[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Software RAID, LVM, and LILO on amd64 sarge

On Nov 4, 2005, at 4:38 PM, Gilles wrote:

During partitioning, I set up both software RAID1 and LVM. After
partitioning, I tried to install LILO in the MBR on /dev/md0, but it
didn't work. I tried advanced mode and tried /dev/mapper/vg-root as
an installation target, but that was invalid, as well.

I think that you have to use an actual disk or disk partition as target. At least, that's how I did it with "grub" where a disk is specified with
something like "(hd0)" and a partition as "(hd0,0)".
To have the loader available, even if one of the disks in the array
fails, you just install it on every disks that composes "/dev/md0".

I thought I had read that grub didn't play well with sarge.

Unfortunately, now I'm struggling even to get RAID1 set up the way I'd like, even without LVM.

Maybe this is about the methodology I'm using rather than a problem with the installer, although I would expect the installer to be a little more intuitive. I have a two-drive machine (two 250 GB drives), and I'd like to configure them in a RAID1 such that each disk is bootable.

I thought that I could just configure each disk with a single physical RAID volume partition and then create a software RAID in which I could create as many partitions as I want, including a /boot partition if need be.

But I'm running into issues with seeing the remainder of the disk space be flagged as "unusable" as soon as I create a partition in the RAID1.

Thomas F. O'Connell
Database Architecture and Programming
Sitening, LLC

110 30th Avenue North, Suite 6
Nashville, TN 37203-6320
615-469-5151 (fax)

Reply to: