[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian Sid amd64 on a Compaq v2310us (status report)

I have previously posted to vox-tech@lists.lugod.org about attempts to
install Linux on my Turion64 based Compaq Presario v2310us laptop. I'm
posting this as a howto to both vox-tech, and also debian-amd64, so that
there should be an internet record of how to get a successful system

In the beginning I tried installing Debian Sid for amd64, but gave up
quickly because I didn't know of wireless drivers for the laptop. I
didn't even keep that installed long enough to bother writing down what
worked and what didn't. That problem could have been resolved way back
then, but I tried a few more distributions before making Debian Sid work

I tried Kubuntu hoary for i386, and the results are documented at
and at
I would bet you're probably going to try to read these. I'm going to
reference some things in those posts, but only for the sake of
contradicting things I said in those posts.

After finding that wireless driver, I reinstalled to Kubuntu breezy for
amd64. That turned out to be a complete disaster, owing in part to some
bugs still outstanding on Debian Sid (they're fixable though and
irrelevant to most people), but also owing to a complete and total melt
down of all of my network drivers, for reasons passing understanding. So
I gave up and installed Debian Sid for AMD64 again.

*** Executive Summary ***
The wireless card needs ndiswrapper to run. The windows driver is
available from acer.

You can either get accelerated video with the fglrx driver but no resume
support, or you can get unaccelerated video with the ati driver, but
with resume support. I chose the latter.

You need kernel 2.6.11 or later to get DMA working.

I don't know anything about the memory card reader, nor do I have
firewire peripherals. It seems that the former probably doesn't work,
but the latter probably does.

*** Specs ***
*** Specs ***
 The specs for this laptop are as follows (copied from
http://reviews.designtechnica.com/review2907_specs14544.html, with
slight modifications to add slightly more techinal information)

Processor:    AMD Turion 64 processor ml-28+ with PowerNow! 1.60GHz
Chipset: ATI
Shipping operating system:    Windows XP Professional for 32-bit with
Service Pack 2
Memory:    512MB DDR SDRAM (2 x 256MB) at 333MHz; maximum memory
Graphics card:    ATI MOBILITY RADEON 200M with 128MB DDR (dedicated)
Hard drive:    80GB Enhanced IDE
Primary CD/DVD drive:    DVD/CD-RW combo drive
Display:    14.0" WXGA High-Definition BrightView Widescreen (1280 x
768) display
Wireless connectivity:    54g Integrated 802.11b/g wireless LAN with
25HSM/SpeedBooster support (based on a Broadcom chipset)
Digital media:    6-in-1 integrated Digital Media Reader for Secure
Digital cards, MultiMediaCard, Memory Stick, Memory Stick Pro,
SmartMedia or xD-Picture Cards (Texas Instruments)
External ports:    3 Universal Serial Bus (USB) 2.0, 1 notebook
expansion port, 1 IEEE 1394 (FireWire)
Communications:    Integrated 10/100Base-T Ethernet LAN (RJ-45
connector), high speed 56K modem (RJ-11 connector)
Dimensions:    13.15" (L) x 9.1" (W) x 1.29" (H) (min) or 1.53" (H) (max)
Weight:    5.38 lb.
Sound:    Altec Lansing

*** Debian Install ***
I installed Debian Sarge, using a netinstall CD over wired ethernet. The
install used Kernel 2.6.8 as the install kernel. As DMA for the ATI
chipset is not supported until kernel 2.6.11, I had another working
computer download kernel 2.6.12 from Debian sid amd64, so that I could
scp it over and install it as soon as possible after the initial install
is done.

After installing the 2.6.12 kernel, I upgraded to Debian Sid, and
installed my favorite packages.

*** Video ***
You can use the ATI driver, or the non-free fglrx driver.

The ATI driver is unaccelerated, but supports suspend/resume.

The fglrx driver is accelerated, but does not support suspend/resume.

I chose the former. To specify that you want unaccelerated video, you
must use the option
        Option          "noaccel"
in Section "Device".
Becuase my cursor looked ugly after that, I also used
        Option          "swcursor"
You may be able to get away without swcursor. Try it. The worst that can
happen is aesthetic problems.

My xorg.conf is attached.

For some reason, I can't use the scroll stuff, and can't get the
typing-disables-trackpad behavior. I could probably reconfigure that,
but I would have to use
	Option "shmconfig" "on"
in the Section "InputDevice" corresponding to the synaptics touchpad.
When I turned that on, things started to crash, so I turned it off. I
might have even had that working on Debian and lost it in a
dist-upgrade. I'm not sure.

If you have a solution, let me know.

You can ignore the other mutterings on vox-tech about synaptics not
working. I know I've gotten it to work fine on at least one of these

*** Video Part 2 ***

Also, don't try to use the vesa framebuffer console. I couldn't get any
backlighting with vga=788. I rebooted quickly and removed the offending
kernel parameter.

*** Wireless Card ***
The wireless card is a broadcom 4318. There is currently no open source
driver for broadcom cards. I used ndiswrapper.

It turns out that although the 64bit wireless driver from linuxant.com
doesn't support the Broadcom 4318 wireless card inside the v2310us,
there's a driver for the card available from acer that does, available

*** Power Management ***
A tip (http://www.lugod.org/mailinglists/archives/vox/2005-08/msg00056.html)
on vox-tech told me to add the 'acpi_sleep=s3_bios' kernel parameter
to make suspend work. (Booting with 'noapic' is also nice for reasons
completely unrelated to power management ... but since I'm on the topic
of kernel parameters ...)

After that, power management is a breeze. Unlike Ubuntu, Debian doesn't
come with a highly-preconfigured acpid. There were some changes I had to
make to configure it.

First, you need to remove or comment out /etc/acpi/events/powerbtn. If
you close and open the lid, the v2310us sends acpi the powerbutton
event, so you don't want this left around otherwise you'll shut down
your laptop whenever you wake it up.

Second, you need to configure whatever you want. For me that was simply
to make it go to sleep when I close the lid. Very simple. I set up
/etc/acpi/events/lid as follows:
event=button[ /]lid
action=/etc/acpi/lid.sh %e

Then I filled in the /etc/acpi/lid.sh
echo mem > /sys/power/state

It works like a charm.

*** Sound ***
Sound worked fine with no additional configuration needed.

*** Bugs ***
There are of course bugs in unstable, and these should be pretty
transient. I wanted to use fluxbox as my window manager, but fluxbox had
 bug #316566 which caused firefox to run but not display any window.
This is fixed upstream in 0.9.14, and should hopefully be in Debian
soon. Other window managers have reported similar bugs, so if you have
problems with that, see if the window manager needs fixing.

I usually have a GPG digital signature included as an attachment.
See http://www.gnupg.org/ for info about these digital signatures.
# xorg.conf.dpkg-new (Xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf.dpkg-new manual page.
# (Type "man xorg.conf.dpkg-new" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#   cp /etc/X11/xorg.conf.dpkg-new /etc/X11/xorg.conf.dpkg-new.custom
#   md5sum /etc/X11/xorg.conf.dpkg-new >/var/lib/xfree86/xorg.conf.dpkg-new.md5sum
#   dpkg-reconfigure xserver-xorg

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"type1"
	Load	"v4l"
	Load	"vbe"

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"auto-dev"
	Option		"HorizScrollDelta"	"0"

Section "Device"
	Identifier	"ATI Technologies, Inc. Radeon Xpress 200M (RS480)"
	Driver		"ati"
	BusID		"PCI:1:5:0"
	Option	        "noaccel"
	Option          "swcursor"

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	DisplaySize     325 195

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies, Inc. Radeon Xpress 200M (RS480)"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x768" "1024x768" "800x600"
	SubSection "Display"
		Depth		4
		Modes		"1280x768" "1024x768" "800x600"
	SubSection "Display"
		Depth		8
		Modes		"1280x768" "1024x768" "800x600"
	SubSection "Display"
		Depth		15
		Modes		"1280x768" "1024x768" "800x600"
	SubSection "Display"
		Depth		16
		Modes		"1280x768" "1024x768" "800x600"
	SubSection "Display"
		Depth		24
		Modes		"1280x768" "1024x768" "800x600"

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice	"Synaptics Touchpad"

Section "DRI"
	Mode	0666

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: