[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Perfomance problems with NVidia

On Wed, 2005-07-06 at 16:16 +0200, Sven Krahn wrote:
> > >Does anybody (Len?) have an idea what the fps rate for FX 5700LE (with
> > >an AMD64 3200+) should be? Mine is at roughly 1450fps (with default
> > >glxgears), though I remember with an earlier nvidia driver I have it
> > >seen at 2700fps already. I have no clue what the benchmark could be...
> > >
> > >
> > >
> > Default glxgears for Athlon XP 2000 with GeForce 5600 FX gets
> > 
> > 16666 frames in 5.0 seconds = 3333.200 FPS
> > 
> > - Adam
> Thanks for all your answers. I have re-tried several configuation
> options but do not come to higher values than 1450fps. I had it up to
> 2700fps (which after reading your replies and the contained links I
> consider to be the benchmark-to-be for this card) before I switched
> from xfree to xorg, and maybe this makes the difference. In xorg, I
> have the compmgr activated, but even without translucency and shadows
> the fps rate doesn't change. Does anybody have any experience
> regarding graphic/glx performance differences between xorg and xfree
> and their respective options?
> Thanks a lot again.

I haven't noticed any differences between xorg and xfree for performance
myself, what I have noticed is that nvidia drivers can give very
different performance on your hardware depending in the version. Perhaps
an older version will give you better performance ?

Out of curiosity what are your values for

That may provide a clue as to why your performance seems a little slow

eg On my (Ubuntu) system I get

jamie@workhorse:~$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA Linux x86_64 NVIDIA Kernel Module  1.0-7174  Tue
Mar 22 06:45:40 PST 2005
GCC version:  gcc version 3.3.5 (Debian 1:3.3.5-8ubuntu2)

jamie@workhorse:~$ cat /proc/driver/nvidia/agp/card
Fast Writes:     Supported
SBA:             Not Supported
AGP Rates:       4x 2x 1x
Registers:       0x1f000017:0x1f000114

jamie@workhorse:~$ cat /proc/driver/nvidia/agp/host-bridge
Host Bridge:     VIA Technologies, Inc. VT8385 [K8T800 AGP] Host Bridge
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       4x 2x 1x
Registers:       0x1f000a17:0x00000114

jamie@workhorse:~$ cat /proc/driver/nvidia/agp/status
Status:          Enabled
Driver:          AGPGART
AGP Rate:        4x
Fast Writes:     Enabled
SBA:             Disabled

So I can see that my card is functioning at it's maximum AGP rate, with
Fast Writes using AGPGART. Perhaps your card is not functioning at top
speed, or the nvidia AGP driver can give better performance ?

GPG/PGP signed mail preferred. No HTML mail. No MS Word attachments
PGP Key ID 0x4B6E7209
Fingerprint E1FD 9D7E 6BB4 1BD4 AEB9 3091 0027 CEFA 4B6E 7209

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: