[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mkinitrd problem

ivelasco wrote:

Hash: SHA1

Hi there!

Currently I?m booting a 2.6.8 smp kernel on a Iwill dk8n board with a
LSI megaraid U320 2X with no probs.I made a initrd image with my modules
and the RAID module is called MEGARAID.I tried to install the last
NVIDIA driver and it recommend to me a later kernel.
OK I downloaded the 2.6.11 and it brings a new module for my controller
that it is called megaraid_mm and megaraid_mbox.As you can see when I
try the mkinitrd, the program doesn't see the megaraid module it crashes
with the next error:


I think you need to take the megaraid module out of /etc/mkinitrd/modules.

My configuration is as follows:

amddata:~# more /etc/mkinitrd/modules
# /etc/mkinitrd/modules: Kernel modules to load for initrd.
# This file should contain the names of kernel modules and their arguments
# (if any) that are needed to mount the root file system, one per line.
# Comments begin with a `#', and everything on the line after them are ignored.
# You must run mkinitrd(8) to effect this change.
# Examples:
#  ext2
#  wd io=0x300

and that worked fine for a 2.6.11 kernel with a megaraid u320 e (pci express) card.



Reply to: